2

Today, I started the MikTeX update program because I needed a newer version of some library. It first wanted to update the base installation and at some point it complained that it couldn't replace some library/DLL, which obviously happened because I still had an instance of pdflatex running somewhere. (Unfortunately, I forgot which library it was...) The only option I had at that point was to cancel the update.

I now have the problem that latexmk doesn't work anymore. I can still use TeXworks and so on, but whenever I use latexmk -pvc -pdf, I get

Can't spawn "pdflatex  -recorder  "test.tex"": No error at ...
...
pdflatex: Command for 'pdflatex' gave return code 65280

If I try to call pdflatex -recorder manually, I get a segmentation fault.

So, I completely removed MikTeX and reinstalled it using the current installer from the MikTeX web site. Still the same problem...

Then I completely removed MiKTeX again and in a desperate effort installed the 32-bit version of MiKTeX (instead of the 64-bit version I had used before). Still the same problem...

Any idea what to do or at least how to debug the problem? I can still use MiKTeX, but I've come to rely on latexmk and right now, with a pending deadline, this is pretty much the worst that could happen... :(

Added:

Below is a screen shot which shows how a Windows error box pops up. It also shows (in the console window) the last part of running pdflatex without the -recorder option, which worked fine.

Screen Shot http://miles.agharta.de/screen.png

closed as off-topic by Mensch, user13907, Andrew, Werner, egreg Jun 9 '16 at 20:39

  • This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • To be clear: if you run pdflatex <filename> from the Command Prompt all is well, but if you run pdflatex --recorder <filename> in the same place and for the same file it goes wrong. Correct? Assuming that is the case, can we have a screen shot of the error? – Joseph Wright Dec 28 '15 at 18:31
  • That is correct, yes. I'll add a screen shot. – Frunobulax Dec 28 '15 at 18:39
  • 1
    Testing with a 'clean' system I get an error with pdflatex -recorder. I suspect there's an issue with the MiKTeX binaries, which would explain why a clean install doesn't help. That can only be fixed by Christian Schenk: report on the MiKTeX mailing list. – Joseph Wright Dec 28 '15 at 19:03
  • 2
    recorder fails for me too and I will make a bug report. And: next time you get a problem don't get in an installation frenzy. Stop and think. – Ulrike Fischer Dec 28 '15 at 19:03
  • 4
    I'm voting to close this question as off-topic because it is solved by an update ... – Mensch Jun 9 '16 at 19:46

Browse other questions tagged or ask your own question.