1

I just installed the Lucida Bright OpenType fonts, and it turns out they don't work with pdfLaTeX, which is what AUCTeX was configured to run with the "LaTeX" command when I first installed it. Now I want to run LuaLaTeX instead so that I can use the Lucida Bright fonts. How do I make that change?

closed as unclear what you're asking by TeXnician, Stefan Pinnow, Bobyandbob, siracusa, Phelype Oleinik Sep 24 '18 at 23:49

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    That sounds like a message I used to get several versions of auctex ago. Which version do you have? – Thérèse Dec 28 '15 at 23:02
  • 4
    @Ruby - Try to set a file local variable at the end of your file: %%% Local Variables: \n %%% TeX-engine: luatex \n %%% End: (Replace \n with RET) – Arash Esbati Dec 28 '15 at 23:03
  • 2
    @Ruby - Did you also hit C-c C-n after setting it? – Arash Esbati Dec 28 '15 at 23:09
  • 1
    @Ruby - I'm afraid then that your AUCTeX is too old; you can find your version C-h v AUCTeX-version RET. Updating your emacs would be a good idea. You have access to many packages incl. AUCTeX via ELPA. – Arash Esbati Dec 28 '15 at 23:12
  • 1
    One way to find the version is to read the opening lines of auctex.el. But if you want to work with luatex, you should use the most recent version of emacs, as well as an up-to-date auctex, because support for unicode has improved dramatically in emacs. – Thérèse Dec 28 '15 at 23:17

Browse other questions tagged or ask your own question.