4

I have just updated to Gnu Emacs 24 and am having trouble getting AUCTeX working. I have used the Emacs package manager to install AUCTeX 11.89, and I have (require 'tex-site) in my .emacs file. But when .emacs is loaded I get the error message: "File error: Cannot open load file, no such file or directory, tex-site"

What am I missing?

8
  • 4
    If you install it with the package manager (ELPA repository) you may not use (requite 'tex-site) in your .emacs. try to remove this part and see if AUCTeX is loaded by default Dec 29, 2015 at 7:45
  • @RomainPicot I have removed (require 'tex-site) from .emacs. I think that AUCTeX is working now since C-c C-c works. But then I get the error message: AUCTeX cannot find a working TeX distribution. As suggested in the error message, I added /Library/TeX/texbin to my PATH (and also /usr/local/texlive for good mesasure) but I still get the same error message about AUCTeX not being able to find a working TeX distribution.
    – Ruby
    Dec 29, 2015 at 17:46
  • 1
    @Ruby: Usually, filenames should be marked up. I can rollback, if you prefer -- there you are
    – user31729
    Dec 29, 2015 at 17:50
  • 1
    @Ruby Terminal output, file names, etc. are marked as code: it's the standard mark-up on the site.
    – Joseph Wright
    Dec 29, 2015 at 17:54
  • 2
    @Ruby tex.stackexchange.com/help/formatting
    – Joseph Wright
    Dec 29, 2015 at 17:57

1 Answer 1

2

Like Romain Picot said, when AUCTeX is installed with the Emacs Package manager, .emacs should not contain "(require 'tex-site)". I also needed to add /usr/texbin to my PATH in my .emacs file:

(setenv "PATH" (concat (getenv "PATH") ":/usr/texbin"))
(setq exec-path (append exec-path '("/usr/texbin")))

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .