1

I have installed biber 1.8.

When I run this minimum biblatex example:

\documentclass{beamer}

\usepackage{lmodern}    
\usepackage[labelformat=empty,font=scriptsize,skip=0pt,justification=justified,singlelinecheck=false]{caption}
\usepackage[style=numeric,backend=biber]{biblatex}
%remove the icon
\setbeamertemplate{bibliography item}{}

%remove line breaks
\setbeamertemplate{bibliography entry title}{}
\setbeamertemplate{bibliography entry location}{}
\setbeamertemplate{bibliography entry note}{}


\begin{document}

\begin{frame}
\frametitle{Phenotypic variability}
\begin{minipage}{.35\textwidth}
    \includegraphics[width=\linewidth]{example-image}
    \captionof{figure}{\cite{Waddington1959}}
\end{minipage}\hfill
\begin{minipage}{.6\textwidth}
    \begin{itemize}
        \item This is a test
        \item This is a test \cite{VanDyk1989}
    \end{itemize}
\end{minipage}\hfill
\begin{itemize}
    \item This is a test
\end{itemize}
\end{frame}

\begin{frame}[allowframebreaks]%in case more than 1 slide needed
    {\footnotesize
    \bibliographystyle{apalike}
    \bibliography{TEST.bib}
    }
\end{frame}

\end{document}

TEST.bib:

@article{Waddington1959,
abstract = {THE battle, which raged for so long between the theories of evolution supported by geneticists on one hand and by naturalists on the other, has in recent years gone strongly in favour of the former. Few biologists now doubt that genetical investigation has revealed at any rate the most important categories of hereditary variation; and the classical 'naturalist' theory-the inheritance of acquired characters-has been very generally relegated to the background because, in the forms in which it has been put forward, it has required a type of hereditary variation for the existence of which there was no adequate evidence.},
author = {Waddington, C H},
doi = {10.1038/1831654a0},
isbn = {0201483645},
issn = {0028-0836},
journal = {Nature},
keywords = {Genetics},
pages = {1654--1655},
pmid = {13666847},
title = {{Canalization of development and genetic assimilation of acquired characters.}},
volume = {183},
year = {1959}
}
@article{VanDyk1989,
abstract = {The way in which proteins attain and maintain their final form is of fundamental importance. Recent work has focused on the role of a set of ubiquitous proteins, termed chaperonins, in the assembly of phage and multisubunit proteins. The range of chaperonin action is unknown; they could interact with most cellular polypeptides or have a limited subset of protein partners. Included in the chaperonin family is the essential heat-shock regulated Escherichia coli groEL gene product. Over-expression of the groE operon in E. coli causes enhanced assembly of heterologously expressed ribulose bisphosphate carboxylase subunits and suppresses the heat-sensitive mutant phenotype of several dnaA alleles. It has been inferred that suppression of heat-sensitive mutations is confined to dnaA alleles and that this confinement could reflect an interaction between the groE operon products and a dnaA protein aggregate at the replication origin. We now report that multiple copies of the groE operon suppress mutations in genes encoding several diverse proteins. Our data indicate a general role for the groE operon products, the GroEL and GroES proteins, in the folding-assembly pathways of many proteins.},
author = {{Van Dyk}, T K and Gatenby, A A and LaRossa, R A},
issn = {0028-0836},
journal = {Nature},
pages = {451--453},
pmid = {2573840},
title = {{Demonstration by genetic suppression of interaction of GroE products with many proteins.}},
volume = {342},
year = {1989}
}

Two things don't work.

First, the references in the text appear as [VanDyk1989] instead of (`Van Dyk and al.').

Second, the last frame only contains the text "TEST.bib" instead of the actual references.

I was wondering how to fix this. I have never used beamer with biblatex before, don't really know the difference between bibtex and biblatex and really just need the bibliography file to work as it does in the original (non beamer) latex document.

  • 2
    looks like that you didn't run biber on your main file. However, with style=numeric you'll get something like [10] in the text. – user2478 Dec 29 '15 at 15:29
  • Thanks! Yes, I get a message to that effect (I compile this in the terminal with pdflatex under ubuntu). But how to do this (run biber on the main file)? And also, is this the right forum to ask that second question or should I move this to the ubuntu forum? And also, what are the other styles available beside numeric? – user1933 Dec 29 '15 at 15:30
  • 1
    you mixed biblatex with the old bibtex. – user2478 Dec 29 '15 at 15:31
  • Could very well be since I don't know what these things are. How should I fix this? – user1933 Dec 29 '15 at 15:32
2

Use

\usepackage[style=authoryear,backend=biber]{biblatex}
\addbibresource{TEST.bib}

[...]

\begin{frame}[allowframebreaks]%in case more than 1 slide needed
    \footnotesize
    \printbibliography
\end{frame}

Then run pdflatex file and biber file and again pdflatex

  • I must be doing something else wrong because running biber defence2.tex yields ERROR - Cannot find control file 'defence2.tex.bcf'! - did you pass the "backend=biber" option to BibLaTeX? (I followed your instructions carefully). – user1933 Dec 29 '15 at 15:38
  • 1
    Don't run "biber defence2.tex" but only "biber defence2" (or biber defence2.bcf) – Ulrike Fischer Dec 29 '15 at 15:40
  • Works perfectly! – user1933 Dec 29 '15 at 15:41
  • Bear in mind if you run into problems that biber 1.8 is quite old. Version 2.3 was released a few days ago (which requires biblatex version 3.2) – PLK Dec 30 '15 at 16:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.