Linux defaults to A4 paper size rather than letter. The only answer I found online was to run pdflatex with the -t flag.

$ pdflatex -t letter myfile.tex

but I get the error:

warning: Could not open char translation file `letter.tcx'.

The first line of my file is


because I'm using someone else's template, found here: http://www.terpconnect.umd.edu/~briankw/resources/resume.cls.

How can I make 8.5x11 inch pdf's with latex, and still use this template?


There's no -t option for selecting the paper format as is the case for dvips; but pdflatex knows the option -translate-file and accepts abbreviations for options, as long as they are unambiguous: thus that cryptic warning.

All TeX distributions I know of, set A4 as the default page size for PDF files generated by pdftex or pdflatex. This can be modified at installation time.

A good solution is to say


that exploits geometry's features to pass the paper size to pdflatex without modifying the standard page make up parameters. It's not necessary to say


because letterpaper is a default option; but it doesn't hurt, either.

Of course, any class can be used in place of article:


Just add the geometry line after the class declaration.

  • I'm using someone else's template, so changing the \documentclass creates errors. I posted a link to the template I'm using. Maybe there's a way that I could pass "letterpaper" in. But I don't know how. – Kevin Sep 16 '11 at 22:49
  • Just add \usepackage[pass]{geometry} after the \documentclass{resume} line. – egreg Sep 16 '11 at 22:55
  • I usually use \usepackage{hyperref} instead of \usepackage[pass]{geometry}, for the same effect. – Jukka Suomela Sep 16 '11 at 23:06
  • 1
    @Jukka: hyperref has many other effects, though. Let's say that using it dispenses from loading geometry or setting the parameters shown in Count Zero's answer. – egreg Sep 16 '11 at 23:11

Most document classes accept options to modify the page size to fit any standard paper size, e.g.:


If you convert then to PDF, it might happen that the page is typeset correctly, but the paper size is different. To avoid this, you can insert into your preamble:


This tells pdfLaTeX to match the paper and the page size.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.