1

I have these labels in the margin everywhere in my final document. I don't think they look good, and I want to get rid of them, but I can't figure out how.

I searched around and this is the closest I could find - https://www.sharelatex.com/blog/2012/01/31/keep-track-of-your-labels-with-showlabels.html

However, the text "showlabels" is nowhere in my files.

\usepackage[nolabel, final]{showlabels} does not remove the labels from the final pdf.

\usepackage[right]{showlabels} also does not move the labels to the right margin, which must mean the labels are coming from something else

Thanks

enter image description here

  • 2
    It's going to be very hard to solve this without seeing the code, unless we already know what would be the cause. Could you post at least the parts of the preamble that refer to figures, labels, etc? – Alenanno Dec 31 '15 at 19:41
  • 5
    This isn't the default, so you've added some package that does it, such as showlabels, showkeys or refcheck. – Torbjørn T. Dec 31 '15 at 19:46
  • 4
    Really though, the best way of solving this, is to make a minimal working example: Take a copy of your document and remove everything in the document environment except one label, or labeled thing. Then start removing stuff from the preamble, piece by piece, until you're left with (probably) just documentclass and one package/definition. You might even work out the root way before then. – Torbjørn T. Dec 31 '15 at 19:52
  • 1
    Do you have draft in the options you are passing to the package class or any package? If so, try removing it. But that's just a guess. As @TorbjørnT. says, without an example of the code which does this, we are in the dark. This just isn't the default behaviour. – cfr Dec 31 '15 at 19:56
  • It was the \refcheck. I was unable to remove it the first time around guessing at the cause, but after cleaning up what relied on it, was able to remove it and get a clean document. Thanks. – SwimBikeRun Dec 31 '15 at 20:02
5

There are at least three packages that do this, see Printing labels along with equation numbers. They are showkeys, showlabels and refcheck. From your comment you seem to have loaded refcheck, and removing that solved the problem.


That said, the best solution to this problem is really just "make a minimal working example". In this case the starting point of making an MWE could be

\documentclass{article}
<your entire existing preamble>
\begin{document}
\label{something}
\end{document}

Then start removing things from the preamble, and you'll quite quickly find the package that produces those labels.

0

I had exactly the same problem, and the fact of explicitly state:

\usepackage[nolabel, final]{showlabels}

had no effect. In my case the "guilty" package was refcheck: After removing this package, labels disappeared.

  • Hi, welcome. The refcheck package was also the "culprit" in the OPs case, as I mentioned in my answer above. – Torbjørn T. Jun 21 '17 at 15:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.