7

I'm trying to have multiple references to a footnotes, in a class memoir (or report) and using [french]babel and cleveref.

According to this question Multiple references to the same footnote with hyperref support - is there a better solution?, I came up with minimal non working example:

\documentclass{memoir}

\usepackage[french]{babel}

\usepackage{hyperref}
\usepackage{cleveref}

\crefformat{footnote}{#2\footnotemark[#1]#3}

\begin{document}
\section{foo}
First page, referencing future footnote\cref{second}.

Second paragraph, first footnote\footnote{\label{first}First footnote!}

\pagebreak
\section{bar}
Second page, creating the second footnote\footnote{\label{second}Second footnote}, 
and referencing the first footnote\cref{first}.
\end{document}

And I get :

footnote reference wrong

As you can see, the reference text is wrong (but the link is ok !). If I replace memoir with article, everything is fine, but report fails also. What can be going on?

Thanks

3
  • 1
    Use \frenchbsetup{FrenchFootnotes=false} in the preamble.
    – egreg
    Commented Jan 2, 2016 at 17:14
  • thanks, that did the trick ! Can i ask where did you find that ?
    – Napseis
    Commented Jan 2, 2016 at 18:49
  • Since the issue appears only with French, I looked in frenchb.ldf and indeed it monkeys with footnotes; this is apparently not at all liked by memoir. Happily, there's a way for disabling the changes. ;-)
    – egreg
    Commented Jan 2, 2016 at 18:52

1 Answer 1

6

The French module for babel does some changes to the footnote management and, apparently, this breaks the cooperation between memoir, hyperref and cleveref.

Add

\frenchbsetup{FrenchFootnotes=false}

to your document preamble in order to disable those changes.

1
  • 1
    I may add this is also useful for report class
    – Napseis
    Commented Jan 2, 2016 at 20:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .