2

I am starting with LaTeX and now I have a problem. I am writing a long document (thesis) and I have a specific LaTeX template which uses the BibTeX package to manage bibliography (as soon as I understand the code). In the past I used to use the natbib package which helps a lot when trying to insert in-text citations.

Now I cannot figure out how to implement the natbib in the main file. How can I 'force' the BibTeX pack to get in-text citations like:

LaTeX is difficult (Guy et al., 2016).

4
  • 4
    Welcome! I think we need a Minimum Working Example (MWE) i.e. a small document showing what you are doing. If you are using a non-standard class or package and that's essential to the question, make sure to provide a link so we can find it. Right now, your question isn't very clear to me. BibTeX is not a package at all - you can't say \usepackage{bibtex}. It is, rather a programme you run to generate citations and bibliographies from a database of entries (.bib file). natbib is one package which enhances the LaTeX/BibTeX combo. So why not just \usepackage{natbib}?
    – cfr
    Jan 2 '16 at 21:59
  • 3
    You are using a template, please tell us which one. I am not a psychic like the guys who provided an answer. I think you just skipped/missed the little la and the template uses biblatex which you are not prepare for. As a result, the citations look strange (no question marks, but bold cite key). So, just as @cfr, i want to see a MWE (or link to the template).
    – Johannes_B
    Jan 3 '16 at 9:05
  • Hi, thanks for the answer I am using this template: people.cs.kuleuven.be/~wannes.meert/adsphd but I cannot figure out how to use in-text citations, I tried adding the \usepackage{natbib} in the preamble of the main file, but it did not work. Jan 3 '16 at 22:30
  • Crosspost: github.com/wannesm/adsphd/issues/48
    – Johannes_B
    Jan 4 '16 at 8:26
3

That template does some funny things. It gives you many options, which as well means many limitations.

For example, you can add an option biblatex as class option to use the modern package, but \bibliography doesn't work anymore, because the macro is redefined. The make script does not run biber even though specified.

If you decide to do the classical way, you can change the \bibstyle (yes, it is called that way). As soon as you load package natbib, the bibstyle is set to plain and can't be changed.

Having said that, i think this question arises from a template bug and should be closed.

To address the little comment in the question: LaTeX is not difficult if you are using the standard. Every template, that defines own commands and macros means extra confusion and more stuff to handle for a starter.

1

You need to (a) load the natbib package with the option authoryear, (b) provide a \bibliographystyle{<some style>} instruction, and (c) use

\citep{<entry key>}

instructions to generate citation call-outs of the desired form.

2
  • 2
    I wouldn't be surprised if Johannes is correct, and the template uses biblatex. If that is the case, then I guess your answer isn't that useful (though of course we'd need more information to be sure about this). Jan 3 '16 at 9:53
  • 1
    @TorbjørnT. - You may very well be correct. Let's hope the OP clarifies his/her document setup.
    – Mico
    Jan 3 '16 at 10:47
0

You need to add a bibliographical style. In this case:

\bibliographystyle{apalike}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.