5

And while we are at it, there is another probable bug in the LuaLaTex OpenType layout code: a couple of non-printing characters (such as 200c, 200d, 200e 200f and so on) do in fact show up in the pdf, even though they should not. I so far used \catcode"200E=9 to ignore them. This is alright for 200e and 200f, but not for 200c and 200d because through ignoring them they also lose their effect, in the case of 200c and 200d the effect should be joining two characters or separating them, respectively.

enter image description here

I also realised that not every font prints these characters: Scheherazade, for example does not, but this is merely because it does not have them as a glyph anyway.

I also thought that maybe this is a feature and not a bug, because after all it is good sometimes to be able to visualise invisible characters -- but then one should also be able to turn off that feature.

The MWE:

% !TEX TS-program = lualatexmk
\documentclass{article}
\usepackage{fontspec}
    \newfontfamily\arabicfont[  Script=Arabic,%
                            Numbers=Arabic,%
                            Scale=MatchLowercase%
                                ]{ArabicTypesetting}%
\newcommand{\arabtext}[1]       % Arabic inside LTR
    {\bgroup\textdir TRT\arabicfont #1\egroup}    
\begin{document}
\arabtext{خانه‌ای}
\end{document}

closed as off-topic by Martin Schröder, Zarko, henrique, Rico, egreg Jan 3 '16 at 22:06

  • This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 4
    it's best to report bugs (or even probable bugs) to the maintainers rather than here, in this case of luaotfload here: github.com/lualatex/luaotfload/issues – David Carlisle Jan 3 '16 at 10:02
  • 4
    I'm voting to close this question as off-topic because it's a bug report that should be reported to the maintainers. – Martin Schröder Jan 3 '16 at 21:19