0

I have the problem, that my footnote number does not appear as superscript at the word. Instead it appears as normal number directly after the word. This is part of a template I should use.
However, the problem seems to be with the macro. If I uncomment the macro, the footnote appears in the superscript, but is than also smaller at the bottom of the page.
I already searched for a solution, but did not find anything.

So, how do I keep the footnote big at the bottom and also appearing as superscript? Also this is similar to the other question (How to set superscript footnote mark in the text body but normalsized in the foot?), I had the specific problem with a macro in my template, which was apparently not correct.

\documentclass[fontsize=12pt,BCOR=15mm,DIV=15,a4paper,headsepline,headings=small,twoside,openright,fleqn,appendixprefix]{scrbook} 
\usepackage[utf8]{inputenc} % Zeichenkodierung
\usepackage[T1]{fontenc} % Trennung von Wörtern mit Umlauten
\usepackage{lmodern} 
\usepackage[hang,stable]{footmisc} %Große Zahlen in Fußnoten
\makeatletter
\def\@makefnmark{\hbox{\normalfont\@thefnmark}}
\makeatother
\let\footnotesize\small
\begin{document}
\begin{enumerate}
\item First item\footnote{adfasdf}
\end{enumerate}
\end{document}
1
  • Check the documentation of KOMA for \deffootnote and \deffootnotemark. Jan 3 '16 at 10:25
1

KOMA has two commands for this purpose: \deffootnote and \deffootnotemark. You want to set \deffootnote:

\documentclass[fontsize=12pt,a4paper,headsepline,headings=small]{scrbook} 
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{lmodern} 
\usepackage[stable]{footmisc}

\deffootnote[1.5em]{1.5em}{1em}{%
  \makebox[1.5em][l]{\thefootnotemark.}%
}

\begin{document}
\begin{enumerate}
\item First item\footnote{adfasdf}
\end{enumerate}
\end{document}
2
  • This looks good, but it seems to me that the size of the footnote text itself looks smaller than the text "First item". Am I right or is this just an illusion? Jan 3 '16 at 11:20
  • @ChristophS - The entire footnote (number and text) is typeset in \footnotesize (10pt for 12pt class option). Yes, it is smaller. Jan 3 '16 at 11:23
0

One can try this (make change of \@makefnmark local)

\documentclass[fontsize=12pt,BCOR=15mm,DIV=15,a4paper,headsepline,headings=small,twoside,openright,fleqn,appendixprefix]{scrbook} 
\usepackage[utf8]{inputenc} % Zeichenkodierung
\usepackage[T1]{fontenc} % Trennung von Wörtern mit Umlauten
\usepackage{lmodern} 
\usepackage[hang,stable]{footmisc} %Große Zahlen in Fußnoten

\makeatletter
\let\old@makefntext\@makefntext
\long\def\@makefntext#1{%
\def\@makefnmark{\hbox{\normalfont\@thefnmark}}%
\old@makefntext{#1}}
\makeatother

\let\footnotesize\small
\begin{document}
\begin{enumerate}
\item First item\footnote{adfasdf}
\end{enumerate}
\end{document}

Not the answer you're looking for? Browse other questions tagged or ask your own question.