I updated to MacTex 2015 from 2013 and I cannot use the garamondx font. Here is an example:






And here is the error:

kpathsea: Running mktexpk --mfmode / --bdpi 600 --mag 1+120/600 --dpi 720 zgmr8r
mktexpk: don't know how to create bitmap font for zgmr8r.
mktexpk: perhaps zgmr8r is missing from the map file.
kpathsea: Appending font creation commands to missfont.log.
!pdfTeX error: /Library/TeX/texbin/pdflatex (file zgmr8r): Font zgmr8r at 720 n
ot found
 ==> Fatal error occurred, no output PDF file produced!

However: I have installed getnonfreefonts, I have done

$ sudo getnonfreefonts -a
$ sudo getnonfreefonts-sys -a

They're all updated and installed. So what's the problem? I have tried doing updmap, as I saw that in some other question, but it didn't work.

By the way, on my first run of getnonfreefonts -a, I got this:

Installing 'zgm.map'...updmap [WARNING]: resetting $HOME value (was /Users/myusername) to root's actual home (/var/root).

Same for all other fonts.

  • 1
    You should never run getnonfreefonts (as opposed to getnonfreefonts-sys) unless you are in an environment that doesn't let you superuser privileges. In any case sudo should not be prefixed to getnonfreefonts. Do an uninstall with getnonfreefonts and retry. – egreg Jan 3 '16 at 20:22
  • Writing $ getnonfreefonts gives ! ERROR: The install directory '/Users/myusername/Library/texmf is not writable. Is this normal? – Bruno Stonek Jan 3 '16 at 20:23
  • Yes, because you used sudo getnonfreefonts (which was wrong to begin with). Unfortunately, there's no uninstall option, so you have to do that manually. – egreg Jan 3 '16 at 20:25
  • No. That is not normal. It is a result of using sudo getnonfreefonts. – cfr Jan 3 '16 at 20:25
  • To do what manually? Set that directory to writable? – Bruno Stonek Jan 3 '16 at 20:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.