1

The last update of alternative4ht, in order to fix the tables in tex4ht see here, has a consequence that the redefinition of \thefootnote with pifont is broken. there are two versions of the redefinition, as explained here. https://tex.stackexchange.com/a/133268/93524

both versions are broken : there is no longer the adequate symbol printed. it s a some vertical bar which is printed, instead of the numbers.

Note that the the command \renewcommand{\thefootnote}{\roman{footnote}} still works, so the problem is with pifont+alternative4ht

This behavior does not appear with the PREVIOUS version of alternative4ht dated 31/12/15, the version which has the problems with tabular.

note that if the packages \usepackage{alternative4ht} and the others are disabled, then the footnote works.

I compile with make4ht -ul hello.tex "fn-in"

I use an extension of tex4ht by @michal.h21,

https://github.com/michal-h21/helpers4ht

\documentclass[oneside,a4paper, 12pt]{article}


\usepackage[bottom, hang, perpage]{footmisc}



%%%\usepackage{pifont}\renewcommand\thefootnote{\scriptsize{\ding{\numexpr171+\value{footnote}}}}


%\renewcommand{\thefootnote}{\roman{footnote}} 


\usepackage{pifont}
\makeatletter
\newcommand*{\circnum}[1]{%
  \expandafter\@circnum\csname c@#1\endcsname
}
\newcommand*{\@circnum}[1]{%
  \ifnum#1<1 %
    \@ctrerr
  \else
    \ifnum#1>20 %
      \@ctrerr
    \else
      \ding{\numexpr 171+(#1)\relax}%
    \fi
  \fi
}
\makeatother

\renewcommand*{\thefootnote}{\circnum{footnote}}





 \usepackage{alternative4ht}
  \altusepackage{fontspec}
  \setmainfont{TeX Gyre Termes}
%%%  \newfontfamily\greekfont{Linux Libertine O}
%%%  \newfontfamily\russianfont{Linux Libertine O}
%%%  \newfontfamily\hindifont{Siddhanta}
  \altusepackage{polyglossia}
  \setmainlanguage{french}
%%  \setotherlanguage{czech}
%%  \setotherlanguage{greek}
%%  \setotherlanguage{russian}
%%  \setotherlanguage{hindi} 
%\usepackage{zref-perpage}
%\zmakeperpage{footnote}



\begin{document}
\footnote{First}
\dots
\addtocounter{footnote}{18}
\footnote{Last}
% \footnote{Error}
\newpage
\footnote{New page}
\end{document}
1

This problem is interesting, you want to use 8-bit font, which doesn't use unicode to output the characters. It works in normal tex4ht using transforming characters through htf conversion tables, but our Lua callback converts each character above ASCII value 128 to unicode char and obeys htf conversion process.

As a solution, only explicitly allowed fonts are processed by Lua callback now. Basic fonts such as cmrm are enabled by default, the disabled ones are printed to the terminal output:

Unsupported font  pzdr

fonts which should be processed with the callback can be enabled using

\Configure{AllowFont}{font pattern)

Please update helpers4ht to get these changes.

Modified sample result:

enter image description here

  • but alternative4ht worked before the update for the tables... how must be used the \Configure{AllowFont}{font pattern) , explicitly with with the pifont ? should I also modify the calling of fonts by fontspec, like for \setmainfont{TeX Gyre Termes} ? Can you put a complete modification of the mwe above ? – Koala Jan 5 '16 at 5:46
  • @Koala it didn't worked before, it was just that it didn't process certain boxes, in this case it was for good, in table example it was bad. You don't need to enable pifont, you should enable only fonts which can contain unicode. You don't need to modify your document at all, it should work – michal.h21 Jan 5 '16 at 12:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.