I downloaded MacTex, install it on my new machine (MacBook Air, Yosemite), but it fail to typeset with the error:

Error: Can't find required tool
/user/texbin/pdflatex  does not exist. TeXShop is ....

I tried again using a mirror site, but the same error occurs. Please help! Many thanks.


Have you checked the path settings in TeXShop or tried reinstalling TeXShop (not TeX distribution)?

The binary of pdflatex is in /usr/texbin/ as a symlink in OS X Yosemite or earlier, but the error message says that TeXShop is trying to invoke /user/texbin/pdflatex, which of course doesn't exist. Thus it might be likely that the path settings in TeXShop is changed for some reason. So, fixing the path setting or reinstalling would settle the problem.

I was not aware that I have to download TexShop separately.

No, usually it's unnecessary because TeXShop is bundled with MacTeX. In your question, however, you installed MacTeX and have trouble with typesetting LaTeX documents while using TeXShop. Then, it's reasonable to think that the cause lies in TeXShop, not in TeX system itself.

It is OK to use TeX IDEs like TeXShop for daily use (they are great softwares!), but I'd suggest that you typeset documents using CLI (command-line interface) when you encounter unfamiliar errors. If it also fails, LaTeX has the problem and if otherwise, the IDE does. Typesetting in two ways can sometimes clarify what is wrong.

PS. I should have posted a comment, but I don't have enough reputation to do that.

  • Sorry: I mistyped the error message. It was /usr/texbin/pdflatex . I was not aware that I have to download TexShop separately. Anyway, I downloaded TexShop separately, and I still cannot typeset, with the same error message, namely Can't find required tool and then /usr/texbin/pdflater etc – Peter Jan 4 '16 at 11:59
  • Then, try running which pdflatex in Terminal and is the result /Library/TeX/texbin/pdflatex? – yudai-nkt Jan 4 '16 at 12:04
  • Yes, it does say /Library/TeX/textbin/pdflatex – Peter Jan 4 '16 at 12:09
  • You can set that path in TeXShop's setting (the third tab from the right side in Preferences). I'm afraid my TeXShop is Japanese localized, so I don't know how the tab is exactly named in English. – yudai-nkt Jan 4 '16 at 12:22
  • I do not know how to typeset with CLI, and I do not know what exactly I should ask for in Preferences within TeXShop. Sorry! – Peter Jan 4 '16 at 13:08

Are you really using Yosemite not El Capitan? Did you install MacTeX-2015?

Recent versions of TeXShop auto-configure to use the proper path to the binaries; /usr/texbin if it still exists or /Library/TeX/texbin if it exists.


/Library/TeX/texbin worked for me, when I set it in:

TeXShop -> Preferences -> Engine -> Path settings -> (pdf)Tex (default: /usr/texbin).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.