3

I'm using TeXstudio on OSX and try as I might I can't get a bibliography to compile.

The main doc of my MWE is main1.tex

\documentclass[]{article}
\begin{document}
  This is a reference to reference \cite{citation123}.
  \bibliographystyle{plain}
  \bibliography{testbib}
\end{document}

My .bib file is testbib.bib

@book{citation123, 
author = "E. Jones", 
title  = "A Book Title", 
year   = "2015" }

When I run Tools>Bibliography, I get this error

Error: One command expansion invalid.
  Parent Command: bibliography
  Primary Command: bibliography

And then when I run pdflatex it gives the warning No file main1.bbl.

I walked through the steps described in the solution given for TeXstudio described here: Biblatex with Biber: Configuring my editor to avoid undefined citations but I always get the errors above. I've tried switching the default bibliography tool to bibtex, bibtex8, and biber; all give the same error. How do I make TeXstudio generate the .bbl file?

  • The " is missing after Jones. – Johannes_B Jan 5 '16 at 17:35
  • Everything said in the biblatex-Editor question is not suited for you, it is a completely different (though related) matter. – Johannes_B Jan 5 '16 at 17:36
  • Fixed the ", thanks. Same error. – Katie R Jan 5 '16 at 18:02
  • in the example, you use the file name \bibliography{testbib}, but the error you show calls the file by another name" testingbibilio.bbl. to be successful, those two names should be the same. (it's not clear from your example where the latter name comes from.) – barbara beeton Jan 5 '16 at 20:35
  • testingbiblio.tex is the name of the main tex document. I just changed the name to main1.tex to make this more clear. The name of my bib file is testbib.bib. I'm fairly certain that my tex and bib files don't need the same names (although I tried making them the same and got the same errors). The warning I get now is No file main1.bbl. – Katie R Jan 5 '16 at 20:54
4

Maybe you should run

latex main1.tex
bibtex main1
latex main1.tex
latex main1.tex

in a command window (terminal window). On my box, the example you have provided compiles like a charm. At least, you'll find out if the problem you see lies with the LaTeX installation or TeXstudio.

If the example works via command/terminal window, then you could change the Build & View process of TexStudio: Options -> Configure TexStudio, select the Build Tab and paste the line below at the Build & View textbox:

txs:///pdflatex | txs:///bibtex | txs:///pdflatex | txs:///pdflatex
  • Huh, that sure worked. It never would have occurred to me to try in the terminal, so thank you for that suggestion. I guess that means the problem is with TeXStudio... – Katie R Jan 5 '16 at 23:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.