7

There are extra spaces around the extensive (indented and long) quotations. My current solution to eliminate them is as follows:

\begin{quote}
\vspace{-\baselineskip}
Lorem ipsum...
\vspace{-\baselineskip}
\end{quote}

Is there any better handling for this issue?

My setup:

\documentclass[12pt]{report}
\usepackage{apacite}
\usepackage{natbib}
5

Without packages, you can redefine quote to issue zero \topsep.

\documentclass{article}
\usepackage{lipsum}

\renewcommand{\quote}{\list{}{\rightmargin=\leftmargin\topsep=0pt}\item\relax}

\begin{document}

\lipsum*[2]
\begin{quote}
\lipsum*[3]
\end{quote}
\lipsum[4]

\end{document}

Maybe you want to set the topsep to another value.

enter image description here

6

The good solution is to use the quoting-package.

\usepackage[noorphans,vskip=0.5ex]{quoting}

Change all your

\begin{quote}
[citation text]
\end{quote} 

to

\begin{quoting}
[citation text]
\end{quoting}

I suggest you read the manual to learn the other useful options.

  • Thanks, but I found another workaround. – Mustafa İlhan Jan 7 '16 at 17:46
2

Below lines worked for all quotes.

\usepackage{etoolbox}
\AtBeginEnvironment{quote}{\vspace{-\baselineskip}} % before block quote
\AtEndEnvironment{quote}{\vspace{-\baselineskip}} % after block qoute
  • 2
    Not really the best idea. – egreg Jan 7 '16 at 18:05
  • @egreg But mustilica deserves honour for trying to find a solution. – Sveinung Jan 7 '16 at 22:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.