1

I am at present typing a manuscript in WinEdt 8.0 and got stuck in the following page set up problem. Please help me out. Allow me to state the situation in short-details.

The publisher demanded that the print out will be done in letterpaper with 11pt font size. Now I am habituated in page set up with a4paper always. Hence I was little confused about but later I changed the option a4paper in the option of \documentclass.

Below I have provided the sample. Please have a look and edit if you wish.

\documentclass[11pt, letterpaper]{document}      
%=========    
\setlength{\topmargin}{-.3in}  
\setlength{\headsep}{0.1in}     
\setlength{\textheight}{9.5in}  
\setlength{\textwidth}{7in}
\setlength{\oddsidemargin}{-.3in} 
\setlength{\evensidemargin}{-.3in}
\setlength{\topskip}{.2in}       
\setlength{\footskip}{.5in}     
%========    
\usepackage{multicol}
\usepackage[letterpaper]{geometry}                  
\usepackage[english]{babel}
%============
\begin{document}
\chapter{Apple}
Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. 

\chapter{Kolkata}
Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. 

    \chapter{Chennai}
text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. 

    \chapter{Mumbai}
Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. Text. text. 

    \end{document}

Now let me tell you my haphazard that I am facing.

(1) I request you to kindly copy and past the above sample in your own WinEdt and compile/run there. Before that, increase the words "text" so many so that in the output each chapter will be at least 4-5 pages long. Its necessary cause then only I will be able to make my situation precise. My problem is: each chapter is having page number at the bottom, in fact at the extreme bottom but the remaining page numbers are in the above, making the page set up proper. Is it possible, that each chapter is starting with no the page number? What command should I use ?

(2)Now the next problem. After the compilation is done, I am getting some blank pages at the end of most chapters with the header name as the chapter name. How to remove that ?

Mean to say, e.g. chapter 2 is ending with one blank page at the end and it is having the header Chapter 2:Bla bla . How shall I remove that blank page ?

Please help me. And also edit the portion in this post if you desire. I have tried my best sincerely to make it clear what situation I am having.

Thanking you

3
  • I think problem one I have managed. I found here tex.stackexchange.com/questions/103567/… the solution how to remove the page number from first page of each chapter. Am I right ?
    – KON3
    Commented Jan 9, 2016 at 9:20
  • 1
    The link should provide at least some ideas. Since you're using geometry, there's no need to manually set the topmargin etc. before. And if there's too less content for pages, an empty page will be used to give the possibility to start on an odd page again (that's the default for chapters, unless openany is used) -- And which is the class document? I think it's a typo and it should read book or report, most likely
    – user31729
    Commented Jan 9, 2016 at 9:38
  • 2
    For this and future problems, I suggest you to use the lipsum package (ctan.org/pkg/lipsum) when you need to type a lot of text just to fill up pages.
    – Enlico
    Commented Jan 9, 2016 at 9:47

1 Answer 1

2

Assuming book class the standard is that chapters start on the right side, i.e. the odd-numbered page (recto page). This will lead to empty even-numbered pages (verso page) occur of course, if there's not enough typesetting content to fill the last page before a new chapter starts.

The openany documentclass option to book allows chapters to start on verso pages. (report uses openany by default)

By default chapters use a numbered start page (the page number is most times at the bottom then), i.e. the pagestyle is plain. If this is not wanted, use \thispagestyle{empty} and the patch command \xpatchcmd which replaces the page style definition.

Removing the page number however omits the information which page it is, of course -- this can be quite confusing.

In addition:

  • Use the various options of geometry package instead of manipulating the internal layout settings directly. Please change the settings to the needs.
  • Use the blindtext package to generate portions of dummy text just to show some effect and filling up the pages.

\documentclass[11pt,openany,letterpaper]{book}      
%=========    
%\setlength{\topmargin}{-.3in}  
%\setlength{\headsep}{0.1in}     
%\setlength{\textheight}{9.5in}  
%\setlength{\textwidth}{7in}
%\setlength{\oddsidemargin}{-.3in} 
%\setlength{\evensidemargin}{-.3in}
%\setlength{\topskip}{.2in}       
%\setlength{\footskip}{.5in}     
%========    
\usepackage{multicol}
\usepackage[headsep=0.1in,lmargin=0.8in,rmargin=0.8in,letterpaper]{geometry}                  
\usepackage[english]{babel}
\usepackage{xpatch}

% Removing plain style and replace it with empty style for the chapter start page
\xpatchcmd{\chapter}{\thispagestyle{plain}}{\thispagestyle{empty}}{}{}



\usepackage{blindtext}
%============
\begin{document}
\chapter{Apple}
\blindtext[12]
\chapter{Kolkata}
\blindtext[10]
\chapter{Chennai}
\blindtext[10]
\chapter{Mumbai}
\blindtext[10]
\end{document}

enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .