1

I can't successfully compile a simple psvectorian example using xelatex.

I found two answers here and here on SE but neither works for me. I have tried

  1. with TeXShop, with the settings shown here.
  2. with the command line, using xelatex test.tex.

Below are the output errors from both attempts.

Where have I gone wrong?

The console from TexShop is as follows:

This is XeTeX, Version 3.14159265-2.6-0.99992 (TeX Live 2015)
(preloaded format=xelatex) restricted \write18 enabled
....
....
(/usr/local/texlive/2015basic/texmf-dist/tex/latex/latexconfig/graphics.cfg)))) (./test.aux) [1] (./test.aux)
xdvipdfmx:fatal: File ended prematurely

Output file removed. ) Error 256 (driver return code) generating
output;
file test.pdf may not be valid.

The error from the command line build is as follows:

/usr/local/texlive/2015basic/texmf-dist/tex/latex/latexconfig/graphics.cfg))))
(/tmp/test.aux) [1] (/tmp/test.aux)
sh: gs: command not found
sh: gs: command not found
sh: gs: command not found
...

The MWE I am using is from the first link, and as follows:

\documentclass{article}
\usepackage{psvectorian,fancyhdr,lipsum,multido}
\pagestyle{fancy}
\fancyhf{}% Clear header/footer
\renewcommand{\headrulewidth}{0pt}% No header rule
\fancyhead[C]{\psvectorian[height=.7\baselineskip]{187}}
\fancyfoot[C]{%
  \makebox[0pt]{\thepage}%
  \smash{\raisebox{-\baselineskip}{\makebox[0pt]{\psvectorian[width=\textwidth,height=\baselineskip]{85}}}}}
\begin{document}

\lipsum[1]

\begin{center}
  \psvectorian[width=.3\textwidth,height=\baselineskip]{47}
\end{center}

\lipsum[2]

\begin{center}
  \quad\multido{\i=102+1}{7}{\psvectorian[height=.8\baselineskip]{\i}\quad}
\end{center}

\lipsum[3]

\end{document}
  • I can compile this successfully with xelatex – user31729 Jan 9 '16 at 11:07
  • 1
    The error message indicates that ghostscript isn't found or not installed at all – user31729 Jan 9 '16 at 11:19
  • yep, a reinstall of gs worked a charm. – Tim Jan 25 '16 at 15:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.