When I use rubber --pdf test.tex && rubber --clean text.tex, I get test.pdf with nothing else in the working directory than test.tex.

But when I use rubber --pdf --clean text.tex, than I get nothing but the text.tex.

How can I fix this behaviour?

Consider this as my test.tex:

% rubber: set program xelatex
\title{\textbf{Welcome to Gummi 0.6.5}}
\author{Alexander van der Mey\\
        Wei-Ning Huang\\
        Dion Timmermann}


\section{Before you start}

You are now using Gummi 0.6.5. Many new exciting features have been added to the 0.6 series. The document editor is now a tabbed instance, allowing multiple documents to be worked on simultaneously. Using the new projects menu, you can group files together for easy access. 

Support for two high-level {\LaTeX} building systems, \emph{rubber}\footnote{https://launchpad.net/rubber/} \& \emph{latexmk}\footnote{http://www.phys.psu.edu/{\textasciitilde}collins/software/latexmk-jcc/} has been added to this release as well. Your preferred typesetter can be configured through the Compilation tab in the Preferences menu. Typesetters that are not installed on your system will not be selectable. 

Added for your viewing convenience is a continuous preview mode for the PDF. This mode is enabled by default, but can also be disabled through the \emph{(View $\rightarrow$ Page layout in preview)} menu. Complementary to this feature is SyncTeX integration, which allows you to synchronize the position in your editor with the PDF preview. 

We hope you will enjoy using this release as much as we enjoyed creating it. If you have comments, suggestions or wish to report an issue you are experiencing - contact us at: \emph{http://gummi.midnightcoding.org}.

\section{One more thing}
If you are wondering where your old default text is; it has been stored as a template. The template menu can be used to access and restore it. 


The rubber man page says

          Remove all files produced by the compilation, instead of building the document.  This
          option  is present in rubber only.  It applies to the compilation as it would be done
          with the other options of the command line, i.e. saying "rubber --clean foo" will not
          delete foo.ps, while saying "rubber --ps --clean foo" will.

so this seems to be the expected behavior.

  • Is there no way to combine this two parameter as shown about to shorten the first command I have listed second in my initial post? – Til Hund Jan 9 '16 at 22:06
  • @TilHund As far as I can see, no. – egreg Jan 9 '16 at 22:08
  • Mh, I think I going to wrote to the developers because I guess in my humble opinion that the mentioned behavior is less likely to be desired: to get only the TeX and PDF output with --clean rather than staying with the TeX file only. – Til Hund Jan 10 '16 at 10:52
  • @TilHund "clean" (from its use in makefiles) normally removes all generated output so its use in rubber seems perfectly natural and expected. Typically use it to get a clean state before starting a job or checking in to source control etc. – David Carlisle Jan 10 '16 at 11:52
  • Would it be feasible for some to have a parameter in rubber to get the behaviour I am speaking about? Or is it just me asking for weird stuff? I mean clean deletes the PDF only in combination with pdf, which I believe is a bit counter intuitive. – Til Hund Jan 10 '16 at 12:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.