5

Is there a way to configure the TeXstudio Internal PDF Viewer to open in a maximized window by default?

I was able to make it always open in a window by going to Options/Configure TeXstudio and then changing the PDF Viewer to txs:///view-pdf-internal --windowed.

However, it always opens in a window of the same horizontal size, no matter if the last time I maximized it before closing.

Thanks for your time.

8
  • Works here. Are you using the latest version? – Tim Hoffmann Jan 12 '16 at 19:15
  • @TimHoffmann Yes I am. No matter what I try, it keeps coming back to the non-maximized state. – MAnd Jan 12 '16 at 20:26
  • Which OS are you using? – Tim Hoffmann Jan 12 '16 at 22:03
  • @TimHoffmann I'm using Windows 8.1 64 bits – MAnd Jan 12 '16 at 23:26
  • Does the window remember its size and position in non-maximized state? – Tim Hoffmann Jan 13 '16 at 21:29
5

I have noticed this problem for a long time; this was one reason I have always thought replacing embedded PDF viewer in TeXStudio by Sumatra PDF. But I think this problem is related to compatibility issues of TeXStudio Embedded PDF viewer with Windows 8/10 64 bits OS or the screen resolution of your computer (16:9 screens are more problematic). In my home I have a desktop computer with 4:5 screen and Windows 7 64 bits and a new laptop with Windows 10 64 bits. TeXStudio with his Embedded PDF viewer is working perfectly in my Win 7 desktop PC, but I have the problem of forgetting "maximized window" by the embedded PDF viewer in my Win 10 Laptop. I managed to get around a solution: the first time you launch the embedded viewer try to maximalise his windows "manually", i.e. by dragging it to the center of the screen, then mouse-dragging the corners of the viewer window to the top right & left corners of your screen. When you are happy with result, close the PDF viewer. The next time you compile a tex file in TeXStudio, the embedded PDF viewer will remember his "maximized window". So the PDF viewer dont save window settings if you use "maximize button" at the top left corner but save them if you do it manually by dragging the corners. Alternatively you can edit the settings:

Geometries\PdfViewerLeft=-8

Geometries\PdfViewerTop=-8

Geometries\PdfViewerWidth=1024

Geometries\PdfViewerHeight=706

Geometries\PdfViewerMaximized=true

of the file C:\Users\UserName\AppData\TeXStudio\texstudio.ini

Note. I have subscribed to "tex.stackexchange" to just answer this question.

3
  • Thanks you, just corrected suggested INI entries to edit, because in texstudio.ini there are two window settings: one for the main editor and one for PdfViewer. – H.Ben Dec 14 '16 at 0:18
  • @H.Ben Thank you a lot for having the trouble of subscribing just to answer my question. And sorry that I missed it for such a long time! Your solution seems to be the best workaround possible, but still does not work for me (not even in my recently bought Windows 10 64bits laptop). After I change the ini file, first time I build/compile, the pdf opes maximized. But when I close it, for some reason Texstudio ini reverts back to the default Geometries settings! No idea why – MAnd Aug 26 '17 at 0:16
  • Sorry for late answer. You have to drag manually window of texstudio PDF previewer so that it fill the full screen (do it manually by dragging previewer borders, right, left and top so that you end with a full screen previewer window) after that close the previewer by clicking on X at the top right. Then TeXstudio will remember this (manually made) full screen previewer for all future compilations of different documents. Now returning to the original problem: after several experimentation of different Laptops I that this problem happens only for Laptops using 1920x1080 resolution. That's sure. – H.Ben Feb 12 '19 at 23:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.