0

So when using \chapter*{} this introduces a blank page before the next \chapter*{} I'm guessing it is because I am using a book format, tried putting it into a new group and clearing double page but this just messes up the whole format.

Is there a way of telling Latex not to include this page.

I include the code of this part of my document in particular:

\chapter*{Resumen}
\section*{Resumen}
Text Here
\section*{Palabras Clave}
a, b, c, d, e
\chapter*{}
\section*{Abstract}
Text Here
\section*{Key words}
a, b, c, d, e

Thank you in advance

5

If all chapters should be opened on any page, use the openany option (as has been recommended by @alwin already. If only particular chapters should open left, it's possible to switch off the openright feature by saying \makeatletter\@openrightfalse\makeatother. Don't forget to restore afterwards.

Some explanation by the definition of the \chapter command (taken from book.cls.

\newcommand\chapter{\if@openright\cleardoublepage\else\clearpage\fi
                    \thispagestyle{plain}%
                    \global\@topnum\z@
                    \@afterindentfalse
                    \secdef\@chapter\@schapter}

As can be seen, each \chapter (regardless whether \chapter or \chapter* is used) uses the same starter code, i.e. it tests whether \if@openright expands to true and does a \cleardoublepage, so it will start on the next odd page. If \if@openright is false, it will use \clearpage and the chapter starts on the next page, (even or odd).

Note I don't recommend various opening styles throughout a document.

\documentclass{book}

\makeatletter
\newcommand{\enableopenany}{%
  \@openrightfalse%
}
\newcommand{\disableopenany}{%
  \@openrighttrue%
}
\makeatother

\usepackage{blindtext}

\begin{document}

\chapter{Foo}
\blindtext[20]


\enableopenany
\chapter*{Foobar}

\blindtext[17]


\disableopenany
\chapter{Foobar again}

\blindtext[20]

\end{document}

enter image description here

4

If you don't want any blank pages in front of all your chapters, you can tell LaTeX to open chapters on any pages.

This is done by: \documentclass[openany]{book}

The default is openright which causes LaTeX to add the additional page in order to make sure that the chapter opens on a right page.

There is additional detail in this answer here: https://tex.stackexchange.com/a/128336/51373

If you simply do not want an empty page between two specific chapters, my method would be: \makeatletter\@openrightfalse before the chapter to turn openright off, then turn it on again after the chapter with \@openrighttrue\makeatother.

Hope it solves your problem!

  • This would enable the openany feature for all chapters then – user31729 Jan 12 '16 at 11:51
  • 1
    It wasn't clear from the question if Neptune wanted to clear the blank page from a single chapter, or all chapters. I assumed the latter, but I'll edit my answer just in case it was the former then – Alwin Jan 12 '16 at 11:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.