1

For this problem, I am using the following MnWE:

\documentclass[fontsize=18pt, paper=letter]{scrartcl}

\usepackage{concmath}
\usepackage[T1]{fontenc}

\usepackage{amsmath}

\begin{document}

\title{A test \LaTeX to HTML page}
\date{}

\maketitle


\section{Section One}

Hello world. Here is some mathematics:
    \begin{equation}
        x + y = 3
    \end{equation}

\end{document}

My build script is:

local filter = require "make4ht-filter"
local process = filter{"cleanspan", "fixligatures", "hruletohr"}
if mode == "draft" then
  Make:htlatex()
else
  Make:htlatex()
  Make:htlatex()
  Make:htlatex()
end
Make:image("png$", "dvipng -bg Transparent -T tight -o ${output}  -pp ${page} ${source}")
Make:match("html$",process)
Make:match("html$", "tidy -m -xml -utf8 -q -i ${filename}")

My style config file is:

\Preamble{xhtml} \Css{body{font-size:1.5em;}} \begin{document} \EndPreamble

The full errors are:

System call: dvips -E -q -Ppdf -f test_article.idv -pp 2 > zztest_article.ps
dvips: Font xccmi10 not found; characters will be left blank.
dvips: Font ccr10 not found; characters will be left blank.
System return: 0
System call: rungs -sDEVICE=pngalpha -sOutputFile=test_article0x.png -r110x110 -dEPSCrop -dBackgroundColor=16#ffffff -dTextAlphaBits=2 -dGraphicsAlphaBits=2 -q -dbatch -dNOPAUSE zztest_article.ps -c quit
System return: 0
System call: if exist zztest_article.ps DEL zztest_article.ps >nul
System return: 0

Indeed, as suggested by the error messages, no math is shown.

If instead, I use lmodern font, then the math shows, but surprisingly, the math quality isn't so great.

Both the drop in quality and the issue with concmath didn't exist before updating to the latest version of make4ht on GitHub.

What is happening?

2

From your error log:

System call: dvips -E -q -Ppdf -f test_article.idv -pp 2 > zztest_article.ps
dvips: Font xccmi10 not found; characters will be left blank.
dvips: Font ccr10 not found; characters will be left blank.
System return: 0

it seems that your build file isn't used, as dvips instead of dvipng is called. dvips has obviously problem with concmath, dvipng seems to work. Try to include the build file explicitly with

make4ht -e buildfilename.mk4 -c configfile filename.tex 

result:

enter image description here

  • One thing that's a curiosity to me is that now \LaTeX isn't rendered correctly -- I am not sure why! Even if I switch back to lmodern, I still have that issue. It used to work fine before, see: i.stack.imgur.com/UMiKO.png -- anyway, not a big issue, so I am not going to make a question about it :p – user89 Jan 13 '16 at 20:41
  • @user89 it is probably also caused by the font size change. I would redefined it like \def\LaTeX{LaTeX} it doesn't look good in HTML anyway – michal.h21 Jan 13 '16 at 20:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.