7

Something is wrong with the Celsius unit and the detect-all option (see below).

enter image description here

I finally removed the detect-all option to fix the problem, but still, there may be some bug here.

MWE:

\documentclass[11pt,a4paper,openright,twoside]{book}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{siunitx}

\begin{document}

\chapter{What is happening here?}

Good: \SI{50}{\celsius}, \SI{30}{\watt\per\meter}.\\
\sisetup{detect-all}
But after \verb=\sisetup{detect-all}=, the celsius unit (and only this one) is in math mode: \SI{50}{\celsius}, \SI{30}{\watt\per\meter}.

\end{document}  

closed as off-topic by LaRiFaRi, Zarko, moewe, Svend Tveskæg, Kurt Mar 15 '16 at 14:53

  • This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    @LaRiFaRi I think I know what's going on here: trying to satisfy all requirements is hard! – Joseph Wright Jan 13 '16 at 9:06
  • 2
    Bibi, no worries, Joseph did not say that you are asking for something special. I guess he was just a bit resigned as he was introducing some fix for some other issue just two weeks ago. As you are having the most recent TL-version, it seems as if you have found some more work for him... We'll see. – LaRiFaRi Jan 13 '16 at 9:17
  • 2
    I'll need to think a bit to find a solution that works for all of the issues: may take a day or so. – Joseph Wright Jan 13 '16 at 9:30
  • 1
    @JosephWright: I just noticed the problem is gone! Thanks! – Bibi Feb 2 '16 at 17:32
  • 5
    I'm voting to close this question as off-topic because it is about a problem with has been fixed in the meantime. – LaRiFaRi Mar 15 '16 at 14:14

Browse other questions tagged or ask your own question.