I started doing LaTeX less than one week ago, so I am completely fresh to the game. To be quick: I am running Windows 8 (probably not relevant), my LaTeX sits on MikTeX 2.9 but I am using Winedt 9 as editor. I want to learn how to make a bibliography for my upcoming thesis. I am using the biblatex package, and I have also loaded the biber package.

In the preamble, I use the commands \usepackage[backend=biber]{biblatex} and \addbibresource{biblatex-examples.bib}, which is the "default" bibliography that came with the biblatex package (located in a directory under MikteX 2.9/bibtex/etx.) In the document, I use the command \cite{aristotle1968} and at before I end the document, I use \printbibliography.

I can LaTeX this with some warnings, but I doesn't BibTeX. It gives me the following error messages:

I found no \citation commands---while reading file test.aux

I found no \bibdata command---while reading file test.aux

I found no \bibstyle command---while reading file test.aux

(There were 3 error messages)

What is wrong? I saw a guy who had the exact same problem here: BibTex error: Can't find any citations, bibdata or bibstyle

But the solution that worked for him, that is specifying the [backend=biber] in the preamble, does not work for me.

Please, help... I have already googled this for three full days and read tons of suggestions...

  • 1
    See tex.stackexchange.com/questions/154751/…. Biber is not a package, it's a tool which is used in place of BibTeX for extracting data from the .bib file.
    – Joseph Wright
    Jan 13, 2016 at 18:43
  • 1
    If you specify backend=biber when you load biblatex, then you need to use Biber (the program) instead of BibTeX (the program). Your editor of choice may be trying to use BibTeX rather than Biber, which then explains why the file test.aux (created when you run LaTeX (for sake of simplicity: the program) on the file test.tex) does not contain the citation information. BibTeX is run on test.aux, while Biber is run on test.bcf (by running LaTeX on test.tex), which should be created given that the file contains \usepackage[backend=biber]{biblatex}.
    – jon
    Jan 13, 2016 at 18:48
  • There are at least two issues here: First and foremost, biblatex-examples.bib does not contain an entry aristotle1968, there are some works by Aristotle, but their keys are aristotle:poetics and so forth. You need to cite an entry that exists, for example \cite{sigfridsson}, or for your fix of ancient Greek philosophers \cite{aristotle:poetics}. Secondly, and also very importantly, your editor seems to run BibTeX and not Biber (which you explicitly requested), see Biblatex with Biber: Configuring my editor to avoid undefined citations
    – moewe
    Jan 13, 2016 at 18:52
  • Crosspost
    – Johannes_B
    Jan 13, 2016 at 19:49
  • 1
    Skynet? Stop being suspicious. You are dealing with computer programs. Please carefully read the links i have been gibing you on LC and stop panicking.
    – Johannes_B
    Jan 14, 2016 at 8:16

1 Answer 1


You should install the Latexify set of macros package, available from WinEdt.org.

It will add a number of items to your WinEdt menus and buttons:enter image description here

After you've compiled your main file with (pdf)latex once, you commpile the bibliography with biber either from the drop-down TeX menu, selecting biber or from the B+ button, and finally recompile with (pdf)latex twice.

  • I have already the Latexify set of macros, but the Biber-option does not appear on my TeX-list in Winedt. Seems like Winedt just refuses to find Biber...
    – EspenJK
    Jan 13, 2016 at 22:36
  • Maybe this is linked to the fact that biber 64 bit is quite recent, and if you had MiKTeX 64 bit, you didn't have access to Biber 32 bit (at least it was not installed on 64 bit systems). Is your installation recent enough?
    – Bernard
    Jan 14, 2016 at 0:04
  • It's all very recent, because I just started using LaTeX. I downloaded MikTeX 2.9, 32 bits, some weeks ago. And I downloaded Biber yesterday...
    – EspenJK
    Jan 14, 2016 at 9:19
  • The only explanation I see is installation of Latexify_9 did not run correctly. Try unstalling (from C:\Users\Your_Name\AppData\Roaming\WinEdt Team\WinEdt 9\Uninstall\LaTeXify), and reinstall it.
    – Bernard
    Jan 14, 2016 at 9:40
  • Thank you @Bernard for your effort to help me. My Winedt does not reside in that folder on my computer, it seems. But I now ran the uninstallation the same way I ran the installation: By simpling dragging the file "uninstall.edt" into Winedt and by choosing "Execute Macro Script" from the "Macros" toolbar. This is the installation mode described at the homepage Winedt.org. However, when I do, it gives me 5 warnings, saying that the following files were not found: ConfigEx\Mainmenu.ini, ConfigEx\Toolbar.ini, Exec\Erase Working Files.edt, Exec\TeX\PDFTeXify.edt, Exec\TeX\TeXify.edt...
    – EspenJK
    Jan 14, 2016 at 11:59

Not the answer you're looking for? Browse other questions tagged or ask your own question.