0

the problem that I have is that some references appears as numbers and some of them appears as author names. The problem is that I only want numbers. The .tex compiles without any error. I tried to edit the bib file but still the reference appears in names and numbers. I tried deleting the .blb file and compile again but nothing was changed. I tried to delete the .aux file and compile again but still it didn't correct anything. The bibliography file was created using BibDesk. I have upload an image to check it out.

\usepackage[sorting=none]{biblatex}

\addbibresource{bib1.bib} 

enter image description here

  • What if you add style=numeric to your biblatex options? – Alenanno Jan 16 '16 at 18:55
  • isn't it biblatex's way of saying that it cannot find the reference. Instead of printing [??] it prints [key]. – ArTourter Jan 16 '16 at 19:00
  • Just did, \usepackage[sorting=none,numeric]{bib latex}, and I got an error Package keyval error:numeric undefined. I have also checked the reference in the bib file and it appears there. – Petros Mourouzis Jan 16 '16 at 19:01
  • No, add style=numeric. But if you still have problems after that, then @ArTourter may be right. Are you sure you're using the right key to call the citation? Check for wrong spellings. – Alenanno Jan 16 '16 at 19:02
  • 1
    The bold-listed entries could not be found. You need to rerun biber, and there should be a warning message to that effect at the end of your .log. – Werner Jan 16 '16 at 19:35
1

Biblatex, unlike bibtex, will use the key in bold in the document, intead of the bold question marks, to show that the reference is not found.

Consider the following example:

\documentclass{article}
\usepackage[sorting=none,style=numeric]{biblatex}
\usepackage{filecontents}

\begin{filecontents}{bib1.bib}
@article{foo,
    author = {foo, h.},
    title = {some random title},
    journaltitle = {a journal},
    year = {2014},
}
\end{filecontents}

\addbibresource{bib1.bib}

\begin{document}

some text \cite{foo} but also \cite{bar}.

\end{document}

It will produce the output

some text [1] but also [bar].

and in the logs, you should see something like:

./main.bbl:
Package biblatex Warning: The following entry could not be found
(biblatex) in the database:
(biblatex) bar
(biblatex) Please verify the spelling and rerun
(biblatex) LaTeX afterwards.

  • Yes, I understand. I mis-believe that if the references are in the .bib file there will be no problem, how do i rerun Biber? – Petros Mourouzis Jan 16 '16 at 19:58
  • I open a terminal window i type biber filename.tex i got ERROR: did you pass the "backend=biber" option to BibLaTeX? @ArTourter – Petros Mourouzis Jan 16 '16 at 20:48
  • biber should be run on the .aux file not the .tex file. you can leave the extension out altogether and it will pick the correct file – ArTourter Jan 16 '16 at 20:52
  • Still the same error: Cannot find control file 'phd.aux.bcf'! - did you pass the "backend=biber" option to BibLaTeX? – @ArTourner... (sorry for the mentions) – Petros Mourouzis Jan 16 '16 at 21:29
  • I put \usepackage[sorting=none, backend=biber]{bib latex} in the code but still nothing – Petros Mourouzis Jan 16 '16 at 22:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.