3

Thanks for so much help from the community I've gotten so far. This is my first time to ask a question since I am really stuck this time. I have quite an advanced template using biblatex-chicago and authordate style citations, but there is one customization that I cannot seem to find any code to solve. I would like periods after each block, so I am using the code as below. However, the problem is that I do NOT want a period after the year if there are "a" and "b" sources for a given author/year. Please see the below MWE if this is not clear. It seems the easiest way to achieve this would be to add some code telling biblatex-chicago to make an exception to the period rule in the case I am specifying.

If you run the MWE you will see the behavior is quite strange, as there is not a period after the year in the "a" citation, but there IS a period after the year in the "b" citation. I really appreciate any help anyone can offer! I look forward to participating in the community.

\RequirePackage{filecontents}
\begin{filecontents}{bibtex.bib}
@online{citekey1,
    title = {Book Title One},
    author = {Last, First},
    date = {1984},
}
@online{citekey2,
    title = {Book Title One},
    author = {Last, First},
    date = {1984},
}
\end{filecontents}

\documentclass{article}

\usepackage[authordate]{biblatex-chicago}
\addbibresource{bibtex.bib}
%adds periods after each "block" in bibliography
\renewcommand{\newblockpunct}{\addperiod\space}

\begin{document}

\cite{citekey1}
\cite{citekey2}

\printbibliography

\end{document}
  • Welcome! Interesting. Is this specific to biblatex-chicago? If I use regular Biblatex with authoryear it is, of course, different formatting, but I don't see the weird period/space in one case but not the other. – cfr Jan 17 '16 at 4:09
  • You're right, I tried using style=authoryear with biblatex and found it does not produce this issue with the inconsistent periods. I wouldn't mind biblatex instead of biblatex-chicago, but I have added quite a few customizations already which I had trouble figuring out in biblatex. Am I kind of correct in my approach of using biblatex-chicago simply because the default authordate seemed to require fewer alterations to get to my desired result than any other bibliography style? – Andrew Jan 17 '16 at 12:55
  • Normally I would say pick the style closest to your requirements and modify that. Some specialist styles as biblatex-apa and biblatex-chicago go through great lengths to comply with their guidelines and can thus be extra hard to modify, that is something you should keep in mind. – moewe Jan 17 '16 at 14:25
2

biblatex-chicago already uses its fair share of periods in the bibliography I think, so maybe you get get by without \renewcommand{\newblockpunct}{\addperiod\space} and any redefinition.

Furthermore, I have very rarely seen anybody redefine \newblockpunct for punctuation, normally people use \newunitpunct, maybe then

\renewcommand{\newunitpunct}{\addperiod\space}

is enough for you as well.

Indeed, \newblockpunct seems to be intended for spacing via the block option (see p. 49 of the biblatex manual), although it can be redefined as pointed out on p. 97. It seems to lack of the finesse of \setunit punctuation, though, as you experienced, we could use

\renewcommand{\newblockpunct}{\setunit{\addperiod\space}}

instead.

\documentclass{article}

\usepackage[authordate]{biblatex-chicago}
\addbibresource{biblatex-examples.bib}
% pick one (or none) of the two lines below
\renewcommand{\newblockpunct}{\setunit{\addperiod\space}}
%\renewcommand{\newunitpunct}{\addperiod\space}

\begin{document}
\cite{knuth:ct:b,knuth:ct:c,sigfridsson}

\printbibliography
\end{document}
  • Hi, thank you so much for this. The command you suggested as an alternative: \renewcommand{\newblockpunct}{\setunit{\addperiod\space}} gave me the expected result! I now have no periods after "a" and "b" years. FYI, I got the idea to use the \newblockpunt command from this guide: khirevich.com/latex/biblatex My document looks really great now. Thank you! – Andrew Jan 17 '16 at 12:56
  • I tried the first command you suggested: \renewcommand{\newunitpunct}{\addperiod\space} and it worked as well. Thanks! – Andrew Jan 17 '16 at 13:07
  • @Andrew If both solutions work, I would definitely go with \renewcommand{\newunitpunct}{\addperiod\space} (though you might find that no modification at all is necessary). – moewe Jan 17 '16 at 14:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.