2

How can I add the Series for books as:

@book{blaa,
    Author = {First Last},
    Publisher = {GAGA Publishing},
    Address = {New York, NY, USA},
    Series = {Lecture Notes in Something Cool},
    Title = {Something Good},
    Volume = {75},
    Doi = {hahahaha/haha},
    Year = {2015}}

I use the following

 \usepackage[
  backend=bibtex,
        citestyle = alphabetic, 
        bibstyle = ieee-alphabetic,  
        sortlocale=en_US,
        sorting=nyt,
        backref=true
        hyperref=auto,
        firstinits=true,
        style=numeric,%style=alphabetic,
        defernumbers=true,
        isbn=false,
        eid=true,
        doi=true,
        series=true,
        bibencoding = utf8
]{biblatex}

But that does not print the DOI and Series only the Volume...?

Update: it works and I used now these settings

\usepackage[
        backend=biber,
        %citestyle = alphabetic, 
        %bibstyle = ieee-alphabetic,  
        sortlocale=en_US,
        sorting=nyt,
        backref=true,
        hyperref=true,
        firstinits=true,
        style=numeric,%style=alphabetic,
        defernumbers=true,
        isbn=false,
        %eid=true,
        doi=true,
        %series=true,
        eprint=false,
        bibencoding = utf8
]{biblatex}
  • books don't usually have a doi? regardless, yo'll need to supply doi ={...} in your bibsource entry – prettygully Jan 17 '16 at 21:49
  • ahh some stupid mistakes in bibtex, brackets forgotten – Gabriel Jan 17 '16 at 22:12
  • 1
    I just tested your .bib entry and got to see the volume as well as the series and DOI. So if you don't get to see it, something else is going on. Please note that biblatex does not know an option eid or series (this causes an error), you can only toggle on or off certain fields (including isbn, url, doi). Please note further that BibTeX cannot really deal with UTF-8 encoding, so backend=bibtex,bibencoding = utf8 is not fully compatible. You also load several bibliography styles citestyle = alphabetic, bibstyle = ieee-alphabetic, is later overwritten by style=numeric. – moewe Jan 18 '16 at 7:34
  • Could you solve this problem? I noticed that in your new question you use Biber and have addressed the problems I mentioned above. – moewe Jan 18 '16 at 13:26
  • I solved the problem, I use now the update posted. – Gabriel Jan 18 '16 at 14:45
1

When using the following settings, the DOI should be printed

\usepackage[
        backend=biber,
        %citestyle = alphabetic, 
        %bibstyle = ieee-alphabetic,  
        sortlocale=en_US,
        sorting=nyt,
        backref=true,
        hyperref=true,
        firstinits=true,
        style=numeric,%style=alphabetic,
        defernumbers=true,
        isbn=false,
        %eid=true,
        doi=true,
        %series=true,
        eprint=false,
        bibencoding = utf8
]{biblatex}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.