1

recently, I've moved my latex editor from the desktop version 'TexMaker' to the online version 'ShareLatex'. Then I've got a bibliography issue - that is, the 'Reference' section is totally missing at the end of the paper, as well as the missing citation. In my paper draft, I was simple using \bibliographystyle and \bibliography to import the style and print the 'Reference' section. Through the desktop 'TexMaker', I can compile it via 'BibTex' once; then compile it again via 'PDFLaTex'. Yet, 'ShareLatex' does not have 'BibTex' compiler. According to their documentation, it is recommended to use \usepackage{biblatex}, \addbibresource, and \printbibliography. But I cannot find a way to import an external bibliography style file. Has anyone encountered a similar issue ?

  • Can you post complete example code that shows your problem? – Arun Debray Jan 18 '16 at 2:07
  • 1
    Sharelatex supports both bibliographies using traditional bibtex style and biblatex style. – Guido Jan 18 '16 at 4:52
  • If by "bibliography style file" you refer to .bst files, you cannot use those together with biblatex (neither on ShareLaTeX nor anywhere else). But you don't have to use biblatex on ShareLaTeX, you can still use standard BibTeX methods, they only recommend biblatex. – moewe Jan 18 '16 at 7:37
  • Thanks for your reply. Yes, by 'the external bibliography style file', I mean a '*.bst' file. Could you tell me more specific about 'you can still use standard BibTeX methods on ShareLatex' ? On my source, I simple use '\bibliographystyle' and '\bibliography'. Through the desktop editor - 'TexMaker', I can compile it via 'BibTex' first; then 'PDFLatex' to generate the 'Reference' and correct citation. But on ShareLatex, there is no 'BibTex' complier option. I can only compile it through 'PDFLatex', which cause no 'Reference' and missing citation. – Shawn Jan 19 '16 at 11:30
1

There seem to be two issues here.

Firstly, biblatex cannot deal with .bst files; it uses its own system of .bbx, .cbx and .lbx files for style definitions. If you want to use .bst files you will have to resort to classical BibTeX. See for example Switching to biblatex: how to load custom elsarticle-harv.bst style, How to use custom bibstyle with biblatex and Biblatex induced headache: Bibliography bst style not found.


Secondly, you seem to think that ShareLaTeX does not support BibTeX. As Bibliography management with bibtex and especially the example on that page demonstrate that fear is idle. ShareLaTeX can very well deal with BibTeX and automatically runs it once you press the recompile button.

In the screenshot below you can see BibTeX project happily working in ShareLaTeX (it is an adapted version of the example linked to above)

screen shot of a BibTeX project in ShareLaTeX

The page merely recommends using biblatex because of its flexibility and localisation facilities. Indeed ShareLaTeX is also fully compatible with biblatex with both the Biber and BibTeX backend and automatically decides which to run.

  • Thanks. The root cause has been identified with the help from ShareLatex support. ShareLatex does support BibTex; yet it seems not to handle the relative path very well. The file location of my '.tex' is not the same as that of '.bib' and '*.bst'. So, to put them under the same path / folder, the problem can be solved. – Shawn Jan 21 '16 at 10:13
0

Problem Solved.

The root cause has been identified with the help from ShareLatex support. ShareLatex does support BibTex; yet it seems not to handle the relative path very well. The file location of my '.tex' is not the same as that of '.bib' and '*.bst'. So, to put them under the same path / folder, the problem can be solved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.