1

I installed a 64bit MikTeX on Windows 10 and trying to get my tex-files compiling again. I'm using luatex as compiler together with latexmk and a simple latexmkrc file.

$pdflatex = 'lualatex %O %S';
$pdf_mode = 1;
$postscript_mode = $dvi_mode = 0;
@default_files = ( 'myfile.tex' );

Calling latexmk from command line shows me the following output:

$ latexmk.exe
Latexmk: This is Latexmk, John Collins, 5 February 2015, version: 4.43a.
Latexmk: applying rule 'pdflatex'...
Rule 'pdflatex': Rules & subrules not known to be previously run:
   pdflatex
Rule 'pdflatex': The following rules & subrules became out-of-date:
      'pdflatex'
------------
Run number 1 of rule 'pdflatex'
------------
------------
Running 'lualatex  -recorder  "myfile.tex"'
------------
Latexmk: Errors, so I did not complete making targets
Collected error summary (may duplicate other messages):
  pdflatex: (Pdf)LaTeX failed to generate the expected log file 'myfile.log'
Latexmk: Did not finish processing file 'projektskizze.tex':
   (Pdf)LaTeX failed to generate the expected log file 'myfile.log'
Latexmk: Use the -f option to force complete processing,
 unless error was exceeding maximum runs of latex/pdflatex.

Then I tried the following:

$ lualatex -recorder myfile.tex
Segmentation fault

I looked at my old installation on my old PC and couldn't find any difference: Same MikTex-Version, same perl, latexmk, lualatex and so on... except the operating system. So I don't know what to do now.

Do you have any idea?

Miktex: 2.9.5800
perl: perl 5, version 22, subversion 1 (v5.22.1)
latexmk: Version 4.43a
lualatex: Version beta-0.80.0 (MiKTeX 2.9 64-bit) (rev 5238)

closed as unclear what you're asking by TeXnician, Stefan Pinnow, Zarko, user36296, Bobyandbob Sep 30 '18 at 19:02

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • I tried the same with the following latex sample and I got the same error. mally.stanford.edu/~sr/computing/latex-example.html – aronadaal Jan 18 '16 at 16:47
  • No problem with TeX Live on Mac OS X – egreg Jan 18 '16 at 16:58
  • 2
    There was a bug with the --recorder option, but it has been fixed: sourceforge.net/p/miktex/bugs/2424 so check if there are updates (see tex.stackexchange.com/questions/108447/… before clicking on the update button). (I have a 32bit miktex here, if the bug is still present in the 64bit miktex you should report it). – Ulrike Fischer Jan 18 '16 at 17:10
  • Thanks you Ulrike. Well the bug seems to be fixed but there is no new version of the package in the repository. I installed my Miktex yesterday and the miktex-luatex-bin-x64-2.9 package was packaged on 2015-12-10. And yes, I synced the package manager ;) – aronadaal Jan 19 '16 at 7:59
  • Any news here? Has it been resolved by updating? – TeXnician Sep 24 '18 at 12:13

Browse other questions tagged or ask your own question.