0

.bib file was generated using Better BibTeX in Zotero. I tried cleaning it with JabRef and it found no issues. Here is the .tex file:

\documentclass[a4paper]{article}
%replace "preprint submitted to elsevier" with page number
\usepackage[]{natbib}

\begin{document}
    \title{Atmospheric aerosols in the human respiratory system}
    \author{Shimon Chen}
    \date{\today}
    \maketitle
    \section{Introduction}

    \section{The upper respiratory tract: how aerosols enter the body}
        \subsection{The nose}
            test1 \citep{scott_theoretical_1978}.
    \section{Pre-alveoli lower respiratory tract}
            test2 \cite{breysse_inhalability_1990}.
    \section{Particulates and the blood-air barrier}
    \section{Summary}
\end{document}
\section{Bibliography}
\bibliographystyle{plainnat}
\bibliography{Test}

And here is the .bib file:

http://tx.technion.ac.il/~shimi/Latex/Test.bib

And this is the terminal output:

> latex Test
This is pdfTeX, Version 3.14159265-2.6-1.40.16 (TeX Live 2015/Arch Linux) (preloaded format=latex)
 restricted \write18 enabled.
entering extended mode
(./Test.tex
LaTeX2e <2015/10/01> patch level 2
Babel <3.9m> and hyphenation patterns for 79 languages loaded.
(/usr/share/texmf-dist/tex/latex/base/article.cls
Document Class: article 2014/09/29 v1.4h Standard LaTeX document class
(/usr/share/texmf-dist/tex/latex/base/size10.clo))
(/usr/share/texmf-dist/tex/latex/natbib/natbib.sty) (./Test.aux)

Package natbib Warning: Citation `scott_theoretical_1978' on page 1 undefined o
n input line 14.


Package natbib Warning: Citation `breysse_inhalability_1990' on page 1 undefine
d on input line 16.


Package natbib Warning: There were undefined citations.

[1] (./Test.aux) )
Output written on Test.dvi (1 page, 936 bytes).
Transcript written on Test.log.

It doesn't matter how many times I run latex & bibtex. Tried copying to a clean folder. Tried deleting all temporary files and running latex->bibtex->latex->latex. Tried pdflatex. Always the same errors and the document has questions marks instead of references. What am I doing wrong?

1

You have

\end{document}
\section{Bibliography}
\bibliographystyle{plainnat}
\bibliography{Test}

So you end the document early and the bibliography is never input (as can be seen from the log that you posted)

\end{document} 

should be at the end...

  • Wow. That was extremely stupid of me. Thanks! – Shimi Jan 19 '16 at 11:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.