(This may be a stupid question, but I'm new to this, and have tried to find the answer elsewhere to no avail.) When I try to update my lyx file using pdflatex after appending a BibTeX-generated bibliography, I get the following error (which I have searched the site for and not found an answer to):


I've inserted something that you may have forgotten. (See the above.) With luck, this will get me unwedged. But if you really didn't forget anything, try typing `2' now; then my insertion and my current dilemma will both disappear.

I first generated this bibtex database on TeXworks, but eventually migrated it to JabRef to fix mistakes and avoid future ones.

Link to the bib file

Anybody know why this would happen?

Edit: When I export the lyx file to LaTeX, and try to typeset it, the console output gives me the following error, which leads me to believe something is going wrong from the start, as it references my very first citation:

! Missing = inserted for \ifnum.


l.4 Audited Media}}{}]{auditedMagazineData}


  • Can you please add a minimal example? Please read wiki.lyx.org/FAQ/MinimalExample – scottkosty Jan 22 '16 at 4:22
  • What would a minimal example be in this instance? Sorry, but I have no idea what's causing the problem. – Dastan Jan 22 '16 at 19:32
  • You get an error. A minimal example would be a small example that allows us to easily attempt to reproduce the error that you get. – scottkosty Jan 22 '16 at 22:39

Several of the abstract fields (such as the one of kalesanUsesFSS) contain unescaped percentage characters, such as "5.2%". This leads BibTeX to consider the rest of the line as a comment, including the final "}".

You may need your replace your "%" by "\%" (not tested).

  • Hmmm I got rid of all the abstracts (didn't need/want them anyway), but now I'm getting a new set of the same error, as follows: ! Missing = inserted for \ifnum. <to be read again> l l.4 Audited Media}}{}]{auditedMagazineData} I was expecting to see <', =', or `>'. Didn't. Are there any other characters I should be looking out for? It looks like JabRef automatically escaped all _'s and &'s, but I went into all remaining notes containing % signs and got rid of those. What other special characters need escaping? – Dastan Jan 22 '16 at 19:25
  • I guess they are the same as for LaTeX: & % $ # _ { } ~ ^ \ – mlep Jan 23 '16 at 21:01
  • See my edit above – Dastan Jan 26 '16 at 23:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.