3

When I try \neq the output looks like =. I found a similar problem - \neq (not equal) command does not work anymore. Doesn't look like my case (see below for details), and don't know how to follow the directions anyway ('Issue \changenotsign after loading it.' - if I put this command after any of my \usepackage{...} I get an error).

An example of my problem:

    %% Based on a TeXnicCenter-Template by Gyorgy SZEIDL.
%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%

%------------------------------------------------------------
%
\documentclass{amsart}
%

\usepackage{amsmath}
\usepackage{amsfonts}
\usepackage{amssymb}
\usepackage{graphicx}
%------------------------------------------------------------
% Theorem like environments
%
\newtheorem{theorem}{Theorem}
\theoremstyle{plain}
\newtheorem{acknowledgement}{Acknowledgement}
\newtheorem{algorithm}{Algorithm}
\newtheorem{axiom}{Axiom}
\newtheorem{case}{Case}
\newtheorem{claim}{Claim}
\newtheorem{conclusion}{Conclusion}
\newtheorem{condition}{Condition}
\newtheorem{conjecture}{Conjecture}
\newtheorem{corollary}{Corollary}
\newtheorem{criterion}{Criterion}
\newtheorem{definition}{Definition}
\newtheorem{example}{Example}
\newtheorem{exercise}{Exercise}
\newtheorem{lemma}{Lemma}
\newtheorem{notation}{Notation}
\newtheorem{problem}{Problem}
\newtheorem{proposition}{Proposition}
\newtheorem{remark}{Remark}
\newtheorem{solution}{Solution}
\newtheorem{summary}{Summary}
\numberwithin{equation}{section}
%--------------------------------------------------------
\begin{document}
\title[Woo]{Woo}
\author{Blah Blah}
\date{23 January, 2016}


\maketitle

\section{Introduction}\label{se.20.10}
My problem, the following comes out like 'q = t = w'
\begin{equation}
  q \neq t \not= w
\end{equation}


\end{document}

Some chatty background:

Almost a newbie (haven't done latex for years / forgotten most of it).

I'm using an old template(TeXnicCenter-Template by Gyorgy SZEIDL) - use to work for me so I'd like to keep it, but I recently downloaded new copy of latex etc onto my ubuntu 14.04. Perhaps the old template and the new latex don't play nicely together?

I'm trying to do something quickly (who isn't), so sorry if something looks a little weird / drawback.

Perhaps should be a separate post but ... in emacs, I used to have a 'pdflatex' option comming off the 'tex' pulldown menu but can't remember how to install this. Could anyone point me in the right direction / links to set that up?

Thank you

9
  • Welcome to TeX.SX! Sorry, I see \neq as it should be: ≠ or do you mean ¬ ? – user31729 Jan 23 '16 at 21:46
  • Thanks - maybe its the document viewer I'm using? I only get a dvi output, and this seem to be opened by the default ubuntu pdf viewer (even though it's not a pdf). Could that be the problem? – AnotherDroid Jan 23 '16 at 21:48
  • Assuming you’re compiling it from the commandline, try calling pdflatex instead of latex. It has with many small improvements, but in particular, it compiles directly and natively to pdf, so can often fix problems like this. – Peter LeFanu Lumsdaine Jan 23 '16 at 21:51
  • @AnotherDroid: I used pdflatex and it works, as well as with latex and xdvi. The \neq command is typeset as ≠, as expected. – user31729 Jan 23 '16 at 21:53
  • Yes, solved! Thanks very much Christian and Peter. Do you want to post as an answer so I can click correct (in case someone else stumbles into the same problem)? – AnotherDroid Jan 23 '16 at 21:56
4

It sounds like this might be a problem in the pdf encoding. Often, compiling the document using pdflatex instead of latex fixes this kind of problem. (Or if you are invoking LaTeX from your editor instead of the commandline, set up your editor to call pdflatex instead of latex.)

There are various other advantages to pdflatex as well, as discussed in e.g. this tex.se question and its answers.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.