3

I need to include the following reference in a paper:

Saussure, Ferdinand de. 2014. Writings in General Linguistics, ed. Simon Bouquet, Rudolf Engler, Carol Sanders, and Matthew Pires. Oxford: Oxford University Press.

The entry in my bib file looks as follows.

@book{saussure14,
Author = {Saussure, Ferdinand de},
Title = {{Writings in General Linguistics}},
Editor = {Bouquet, Simon and Engler, Rudolf and Sanders, Carol and Pires, Matthew},
Publisher = {Oxford University Press},
Address = {Oxford},
Year = {2014}}

I'm using natbib.sty and linquiry2.bst. When I compile the pdf, I get the following.

enter image description here

Short of hacking linquiry2.bst, is there a generalized way of getting this kind of bibliographic entry?


EDIT (16/03): MWE, as requested.

\documentclass{article}
\usepackage{natbib}
\begin{document}

Theoretical syntax rocks, as noted in \citet{saussure14}.

\bibliographystyle{linquiry2}
\bibliography{refs}
\end{document}

Where refs.bib includes solely the book entry above. Screenshot of compiled pdf.

enter image description here

1
  • I want the reference to display the names of the volume editors (see the bib entry at the top of my original post), so that it reads Saussure, Ferdinand de. 2014. Writings in General Linguistics. Simon Bouquet, Rudolf Engler, Carol Sanders, Matthew Pires (eds.). Oxford: Oxford University Press. Which is the proper reference, as per the OUP site for the book (global.oup.com/academic/product/…).
    – Koldito
    Commented Mar 17, 2016 at 13:56

3 Answers 3

1
+150

If you only have that one entry with editors, you can change the Title field in refs.bib to the following:

Title = {{Writings in General Linguistics}\emph{, ed. Simon Bouquet, Rudolf Engler, Carol Sanders, and Matthew Pires}},

That should produce exactly the result you're looking for. No need to change anything else.

If that's ugly, other options are using custom-bib, hacking linquiry2.bst (as you mentioned), or switching to BibLaTex.

0
3

I have done a bit of reading and I assume you chose the bibliography style because of some external requirement. The linquiry2 has been designed to adhere completely to the specifications set out by the editors of Linguistic Inquiry.

In their submission guidelines, it is clearly stated that books should be cited using either the author(s) or the editor(s). As such, the only correct solution to your problem is to delete the Author tag in your .bib file. Using your MWE and the edited bibliography entry

@book{saussure14,
Title = {{Writings in General Linguistics}},
Editor = {Bouquet, Simon and Engler, Rudolf and Sanders, Carol and Pires, Matthew},
Publisher = {Oxford University Press},
Address = {Oxford},
Year = {2014}}

The resulting document looks like this: enter image description here

If you want both author and editor in your bibliography, the simplest solution is to find or create a style which supports this. Hope that helps you out.

3

Try @incollection with booktitle instead of title:

@incollection{saussure14,
Author = {Saussure, Ferdinand de},
Editor = {Bouquet, Simon and Engler, Rudolf and Sanders, Carol and  Pires, Matthew},
booktitle = {{Writings in General Linguistics}},
Publisher = {Oxford University Press},
Address = {Oxford},
Year = {2014}}

This works fine for me (except there's an "In" which maybe bothers you):

enter image description here

If you want to hack linquiry2.sty, just click or find FUNCTION {format.in.ed.booktitle} and replace it with:

FUNCTION {format.in.ed.booktitle}
{ booktitle empty$
{ "" }
{ editor empty$
    %% Added: "t" change.case$  (Alexis)
    { word.in booktitle "t" change.case$ emphasize * }
    { booktitle "t" change.case$ emphasize
      ", " *
      editor num.names$ #1 >
        { bbl.editors }
        { bbl.editor }
      if$
      * " " *
      format.in.editors *
    }
  if$
 }
if$
}

You will get this:

enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .