0

I am writing a document in LyX which involves citations only. There is no text or anything else that could cause trouble.

My problem: LyX does not generate either the citations or the bibliography. In the PDF, I see only question marks and no References section.

I have been using LyX for a couple of years and it is only in the new versions that I face this problem.

What I have done:

  • Insert>List/TOC>Bibtex Bibliography>Add database, change the style to chicago (or any other, this has no influence.)
  • In the text itself: Insert>Citation>Added a citation from the left column to the right column>Ok.
  • clear biber cache.
  • Selected alternatively "Default", "Natbib" and "Jurabib" in the citation style and selected "biber","bibtex","bibtex8"

I can see both the BibTeX generated bibliography and the citation. When I put the pointer on the first, I see the name of the database and the options, which leads me to believe that LyX is capable of "reading" the file from BibTeX. For the citation, when I put the pointer on it I can see the content of the key.

I am using LyX 2.1.4 (latest version), JabRef 2.8.1 and Adobe Acrobat Reader DC. I have updated through the MiKTeX Package Manager the packages that could be updated.

I have seen in several threads here on stackexchange that this could be due to the LyX pipe. I do not know what this is nor what it does. In the Tools>Preferences>Paths, the LyXServer pipe field is empty. Is this a problem? If so, where is this "pipe" ?

Thank you very much !

  • Did you try adding to the code \nocite{*}? Comments aside, the present version of JabRef is 3.2, and you should use aTex-friendlier pdf viewer, such as SumatraPDF, which doe not lock pdf files. – Bernard Jan 27 '16 at 15:24
  • Thank you. I have tried the 'nocite' option and it works. Before that, I exported from LyX to Latex(plain), opened it in Scientific Workplace where the citation became encapsulated "citet" objects. I opened that file in LyX and then it worked. Could you post your comment as an answer so that I can accept it ? – user89073 Jan 27 '16 at 16:21
  • However, as I understand it, the nocite lists all elements in the database, even those who are not referenced. This is not what I would like. – user89073 Jan 27 '16 at 16:29
1

If the references are not explicitly cited in the text, they won't be printed. So you can try adding nocite{*} to your code, so that the whole .bib file will appear.

Also note that, with biblatex, you can filter what will be printed, e.g. by type (\printbibliography[type=book]).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.