0

I recently upgraded to debian 8 and one of my latex file does not function properly anymore. pdfTeX version is no: Version 3.14159265-2.6-1.40.1. I do not know what it was before that.

Here is a minimal NOT WORKING example that used to work before; although I am rather confident the error lies somewhere here, this is not the complete code.

I looks like the error is in the option following \begin{scope}[...], but I cannot figure out where.

\documentclass{article}
\usepackage{tikz}
\usepackage[paperwidth=22cm,paperheight=29cm,left=0cm,top=0cm,bottom=0cm,right=0cm]{geometry}
\usetikzlibrary{calendar,positioning,folding}

\begin{document}
\begin{tikzpicture}

\begin{scope}[xshift=0cm, yshift=-5cm,
transform shape,
every calendar/.style={
at={(-8ex,4ex)},
week list,
month label above centered,
month text=\bfseries\textcolor{blue}{\%mt} \%y0,
if={(Sunday) [black!50]},
if={(Saturday) [black!50]},
if={(equals=2015-09-25) [blue, font=\bf]},
if={(equals=2015-10-16) [red, font=\bf]},
if={(equals=2015-11-13) [red, font=\bf]},
if={(equals=2015-12-11) [red, font=\bf]},
if={(equals=2016-01-08) [red, font=\bf]},
if={(equals=2016-02-12) [red, font=\bf]},
if={(equals=2016-03-11) [red, font=\bf]},
if={(equals=2016-04-08) [red, font=\bf]},
if={(equals=2016-05-13) [red, font=\bf]},
if={(equals=2016-06-10) [red, font=\bf]}
}]

\tikzfoldingdodecahedron[
folding line length=2.5cm,
face 1={ \calendar [dates=2015-09-01 to \the\year-09-last];},
face 2={ \calendar [dates=2015-10-01 to \the\year-10-last];},
face 3={ \calendar [dates=2015-11-01 to \the\year-11-last];},
face 4={ \calendar [dates=2015-12-01 to \the\year-12-last];},
face 5={ \calendar [dates=2016-01-01 to 2016-01-last];},
face 6={ \calendar [dates=2016-02-01 to 2016-02-last];},
face 7={ \calendar [dates=2016-03-01 to 2016-03-last];},
face 8={ \calendar [dates=2016-04-01 to 2016-04-last];},
face 9={ \calendar [dates=2016-05-01 to 2016-05-last];},
face 10={\calendar [dates=2016-06-01 to 2016-06-last];},
face 11={\calendar [dates=2016-07-01 to 2016-07-last];},
face 12={\calendar [dates=2016-08-01 to 2016-08-last];}
];

\end{scope}
\end{tikzpicture}
\end{document}

Any help would be greatly appreciated.

Best,

Output file shows this:
Overfull \hbox (636.42229pt too wide) in paragraph at lines 48--49 [][]
[1{/var/lib/texmf/fonts/map/pdftex/updmap/pdftex.map}] Overfull \vbox (730.78249pt too high) has occurred while \output is active
[2] (./arteos_X.aux) ) (see the transcript file for additional information)

  • Can you add the exact error in the question too? Thanks. – Rmano Feb 1 '16 at 6:52
  • Done. hope it helps. There are more errors pertaining to my pdf viewer but i don't think they are relevant. – jejuba Feb 3 '16 at 6:27
  • 1
    The compilation is fine... but, since 1st Jan. 2016, \the\year is 2016. In your code, try to replace \the\year by 2015... – Paul Gaborit Feb 3 '16 at 6:45
  • ok thanks. indeed it works fine! how to I check the correct answer since it's a comment you made? – jejuba Feb 6 '16 at 8:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.