2

Here is MWE which returns me two references citations. The article citation appears in single quote and I want double. For the conference, I need the conference title in Italics and correct the word "in" from italics to normal.

\documentclass[a4paper,11pt,Times]{article}
\usepackage[english]{babel}
\usepackage[a4paper]{geometry}
\usepackage{csquotes}
\usepackage{natbib} 
\bibliographystyle{agsm}
\begin{document}

The first reference is  \citep{AAA} where I need to put Double Quotes in the title.
In the next ref \citep{BBB} I need the title of proceeding to be in italics.

\bibliography{biblio}{}
\end{document}

and the bibtex file...

@ARTICLE{AAA,
  author = {Authors1},
  title = {The title of the paper},
  journal = {A Journal},
  year = {2000},
  volume = {1111},
  pages = {111--222},
  number = {5}
}

@CONFERENCE{BBB,
  author = {Authors2},
  title = {\enquote{The title of second citation}},
  booktitle = {International Conference},
  year = {2000},
  address = {Country},
  month = {Month}
}
3
  • 1
    You don't format inside your *.bib file. This is done by the bibliography style you tell your bibliography package to use (in oyur case natbib). I would highly suggest to use biblatex however, since this is really much more easier to handle and provides several very good styles out of the box. Feb 2, 2016 at 11:09
  • @HATEthePLOT I have removed commands for quotations from bibtex file. But \usepackage{biblatex} is not working with \bibliographystyle{agsm} ... what do I do ? Feb 2, 2016 at 15:20
  • Please take a look at the package documentation. Some things are handled differently by biblatex. Feb 2, 2016 at 16:55

1 Answer 1

1

With biblatex your MWE should look like this and should provide your requests out of the box (cf. here):

\documentclass[a4paper,11pt,Times]{article}
\usepackage[english]{babel}
\usepackage[a4paper]{geometry}
\usepackage{csquotes}
\usepackage[style=authoryear]{biblatex}
\addbibresource{bibliography.bib}
\begin{document}

The first reference is  \parencite{AAA} where I need to put Double Quotes in the title.
In the next ref \parencite{BBB} I need the title of proceeding to be in italics.

\printbibliography
\end{document}
4
  • Still getting the following error... ("C:\Program Files\MiKTeX 2.9\tex\latex\biblatex\biblatex.cfg"))) ! Undefined control sequence. <argument> ...docsvlist \expandafter {\bbl@loaded }\ifboolexpr { not test {\... l.7 \begin{document} ? Process has been terminated ... Feb 3, 2016 at 8:11
  • Can you give more details from the log please? Feb 3, 2016 at 9:50
  • The log file is too long and quote only the a few more lines from within ... Cannot pastethe full log here... Package biblatex Warning: No "backend" specified, using Biber backend. (biblatex) To use BibTeX, load biblatex with (biblatex) the "backend=bibtex" option. Feb 3, 2016 at 10:17
  • 1
    ok this is actually enough. It tells you to specify a backkend where you can choose between bibtex or biber. \usepackage[style=authoryear, backend=biber]{biblatex} should do the trick. Be aware that you have to run biber instead of bibtex to create your bibliography. Feb 3, 2016 at 10:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .