2

I am using Lyx 2.1.4 on a Windows System. When i need to create a subsection/pragrah i used the standard shortcuts Alt+A 1-5.

For some reason the shortcuts are now disabled (which lyx tells me down in the statusbar) and restarting lyx (as stated in other posts) did not work.

I did not change anything in my preferences lately except adding the hunspell directory.

How can i enable them again?

  • Are you by chance remembering the shortcut incorrectly? It should be Alt+P 1-5 – scottkosty Feb 3 '16 at 16:56
  • @scottkosty you were kind of right. ALT+P worked. But i was 100% sure i used ALT+A before, so i played with the options. I changed the Interface language to English (from German), since i am writing an English Text, and somehow this changed the shortcut to ALT+P. Thank you. – Nicolas Antor Feb 4 '16 at 10:24
  • Strange. I'm not sure what happened then. The shortcuts should not depend on the language (except for the Qt accelerator shortcuts). I'm glad that Alt+P works. Hopefully it is not too annoying for you to switch from Alt+A to Alt+P. – scottkosty Feb 4 '16 at 17:15
2

The default shortcut (independent of language) is Alt+p 1-5.

However, it is possible to change the shortcut or add an additional shortcut that maps to the same functionality so that is probably why Alt+a worked for you before. Also, it's possible that Alt+p1 was different in LyX 2.0.x. In LyX 2.1.x (and also in the forthcoming LyX 2.2.x) Alt+p1 is used for inserting arguments.

Note that to define your own shortcuts, go to Tools > Preferences > Editing > Shortcuts. I'm actually not sure if it's currently possible to define multi-sequence shortcuts like the ones above.

Note also that your custom shortcuts are saved in the user.bind file. On Ubuntu, this file is located at ~/.lyx/bind/user.bind.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.