1

That might be a very simple problem, but I don't seem to understand why it doesn't work. I have a LaTeX document for which I want to add a bibliography.

I have a document called Bibli.bib which is like this

 @article{Reference1,
Author = {Chris Cavette \& David N. Ford},
Title = {How Printed Circuit Boards Are Made.},
url = {http://www.madehow.com/Volume-2/Printed-Circuit-Board.html}
Year = {Last accessed on 03/02/2016}}

in my main document, I have a paragraph, after which I put \cite{Reference1}.

I use \bibliographystyle{unsrt} because I want to display the URL (and it doesn't work with plain).

But instead of getting number for references [1], I get [Ford()].

I don't understand cause it's the first time that happens to me.

I don't use the natbib package here, but if I do and change the style to unsrtnat, then in the reference page I lose the [Ford()], and in the text itself, it stays Ford, instead of [1]. Cheers

EDIT: It's hard ot put a runable example but here's the part of my code:

\begin document
couche étant séparée par une couche isolante. De cette facon, il est possible de connecter les composants à la surface directement à une certaine couche en percant des trous d'une profondeur spécifique\cite{Reference1}.
    \newpage

    \bibliographystyle{unsrt}
    \bibliography{Bibli.bib}
    \end{document}
5
  • 1
    Please provide a compilable example, not just a .bib file
    – user31729
    Feb 3 '16 at 22:51
  • I added some part of code you can use Feb 3 '16 at 22:55
  • Can you check, if there is a comma missing after the url? Feb 3 '16 at 22:56
  • 1
    At one point, you state that you use the bibliography style unsrtnat, but later on you state it is unsrt. Please advise which style you use.
    – Mico
    Feb 3 '16 at 22:57
  • The unsrt and plain bibliography styles do not recognize a field named url, and hence don't process its contents. If you want to have entries with fields named url, you should use plainnat or unsrtnat. The styles generate identically formatted entries; their only difference is that the latter doesn't sort the entries alphabetically.
    – Mico
    Feb 3 '16 at 23:05
2

If you want to use the unsrtnat bibliography style and generate numeric-style citation call-outs, be sure to also load the natbib package with the option numbers in the preamble:

\usepackage[numbers]{natbib}

Three additional, separate issues:

  • You're missing a comma at the end of the url field.

  • The keyword to be used to separate authors is and, not \&. Thus, please write the author field as follows:

    Author = {Chris Cavette and David N. Ford},
    
  • Don't use the @article entry type unless the piece is published in a journal. For the entry at hand, @misc would seem to be more appropriate.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.