4

I'm trying to use the Myriad Pro Condensed font, but for some reason LaTeX cannot find it. I installed the font using the FontPro scripts. I can get light, normal, bold and extra bold variants, but not condensed, even though FontPro clearly installed all condensed variants. When I try to use the condensed font, I get the following message (both with OT1 and T1 encoding, here shown with T1 encoding):

LaTeX Font Warning: Font shape `T1/MyriadPro-OsF/c/n' undefined (Font) using `T1/MyriadPro-OsF/m/n' instead on input line 11.

Here is my minimal working example:

\documentclass{article}
\usepackage{MyriadPro}
\begin{document}
Hello, World!

{\sffamily 
Hello, World!

\fontseries{c}\selectfont Hello, World! NOT CONDENSED

\fontseries{b}\selectfont Hello, World!

\fontseries{l}\selectfont Hello, World!

\fontseries{bx}\selectfont Hello, World!
}
\end{document}

And here is the result I get:

Myriad Pro not condensed

Is there something wrong with my installation of the Myriad Pro font?

  • Have you tried compiling your document with either XeLaTeX or LuaLaTeX, loading the fontspec package, and using the \setsansfont instruction to load the font? – Mico Feb 4 '16 at 12:54
  • Which operating system and which TeX distribution do you use? – Mico Feb 4 '16 at 13:01
  • 1
    @mico, OS X 10.11.3, MacTex 2015 – m0squito Feb 4 '16 at 16:50
  • Myriad Pro Condensed should be installed as a system font on your computer. Is there something making you shy away from either XeLaTeX or LuaLaTeX? – Mico Feb 4 '16 at 19:50
  • 1
    The main thing to do, when switching from pdfLaTeX to either XeLaTeX or LuaLaTeX, is not to load the inputenc and fontenc packages. – Mico Feb 5 '16 at 2:55
3

How to use the condensed fonts of MyriadPro with pdftex

I had much help by Ulrike Fischer and a useful hint by David Carlisle to find this solution:

\documentclass[fontsize=16pt]{scrartcl}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
%\usepackage{lmodern}
\usepackage[medfamily]{MyriadPro}

\sffamily%to load the fd-file

\DeclareFontShape{T1}{MyriadPro-OsF}{c}{n}
     {<-> MyriadPro-Cond-tosf-t1--base}{} %

\DeclareFontShape{T1}{MyriadPro-OsF}{c}{it}
     {<-> MyriadPro-CondIt-tosf-t1--base}{} %

\DeclareFontShape{T1}{MyriadPro-OsF}{bc}{n}
     {<-> MyriadPro-BoldCond-tosf-t1--base}{} %

\DeclareFontShape{T1}{MyriadPro-OsF}{bc}{it}
     {<-> MyriadPro-BoldCondIt-tosf-t1--base}{} %

\usepackage{MinionPro, blindtext, fontaxes}

\begin{document}

\section{\rmfamily{} MinionPro}
\label{CLA:minionpro}

Some Text with different fonts from MinionPro:

Hello World! -- Regular shape.

\emph{Hello World in itshape} \verb|\emph{...}|

\textsw{Hello World! »Swashed: ABCDEFG«:} \verb|\textsw{...}|

\textssc{Hello World! textssc:} \verb|\textssc{...}|


\section{MyriadPro}
\label{CLA:myriadpro}

\sffamily 

Now, we change to MyriadPro, using \verb|\sffamily|
\bigskip

\fontseries{ub}\selectfont Hello World ! \% BLACK

\fontseries{eb}\selectfont Hello World ! \% bold, because of option medfamily

\fontseries{b}\selectfont Hello, World! \% semibold (option medfamily)

\fontseries{n}\selectfont Hello, World! \% regular

\fontseries{l}\selectfont Hello, World! \% light


\section{\fontseries{bc}\selectfont MyriadProCond}
\label{CLA:myriadprocond}

\fontseries{c}\selectfont 
We even can use the condensed fonts of MyriadPro:
\bigskip{}

Hello World! \% Condensed! (World shrinks?)

\emph{We can use italics and write: Hello World!} 

\fontseries{bc}\selectfont Hello World! \% BoldCondensed

\emph{Hello World! BoldCondIT!}

\end{document}

OK, and it looks like this:

Printout of MyriadPro


(Old answer deleted)

  • According to many manuals, c option certainly exist. Look for instance at this answer and see the list of possible combinations - it's a lot longer than the ones you listed. Am I missing something? – m0squito Feb 4 '16 at 16:46
  • 1
    Yes, in theory, but not here in the MyriadPro package. Please, read the manual: texdoc MyriadPro. – Keks Dose Feb 4 '16 at 17:28
  • 1
    I see.. So this means there is no way to use MyriadPro condensed fonts with LaTeX? I have to use Xe/LuaTeX to achieve that? – m0squito Feb 4 '16 at 18:01
  • The best is to ask directly @sebschub if he could add a new branch to support the condensed version of MyriadPro, as he did to support the light version. – s__C Feb 5 '16 at 10:37
  • 2
    @m0squito New answer -- it works! – Keks Dose Feb 5 '16 at 17:12
1

(Too long for a comment, hence posted as an answer.)

If you have access to the Opentype version of the Myriad Pro Condensed font, you may want to look into using either XeLaTeX or LuaLaTeX, as both can handle Opentype fonts directly. (On my system -- MacTeX2015, MacOSX 10.11.3 -- the font Myriam Pro Condensed is installed as a system font in opentype format.)

The following screenshot was generated with XeLaTeX:

enter image description here

% !TEX TS-program = xelatex
\documentclass{article}
\usepackage{fontspec}

\begin{document}
\setsansfont{Myriad Pro Condensed}
\sffamily 

Hello, World!

{\bfseries Hello, World!}

{\itshape Hello, World!}

{\bfseries\itshape Hello, World!}

\medskip
\setsansfont{Myriad Pro} % not "Condensed"
\sffamily
Hello, World!

{\bfseries Hello, World!}

{\itshape Hello, World!}

{\bfseries\itshape Hello, World!}
\end{document}
  • I appreciate the answer, although I am not using Xe/LuaLaTeX. – m0squito Feb 4 '16 at 16:48
  • 1
    Is there any reason why you're not using xelatex or lualatex? – Joseph Feb 4 '16 at 20:23
  • Well, compiling is slooooooooooooow. – Keks Dose Feb 5 '16 at 10:23
  • 2
    @KeksDose - The compilation speed under LuaLaTeX depends very much on the local settings. On some systems (such as mine, MacTeX2015 and MacOSX 10.11.3), only the first run is slow, but that's because a large font cache file has to be built. The speed of subsequent runs is pretty much indistinguishable from what's available with pdfLaTeX (of course, using latex files for which compilation is possible in both formats). If LuaLaTeX is permanently slow on your system, you may want to check whether the font cache file is being rebuilt every single time; if so, do look into changing that setting. – Mico Feb 5 '16 at 10:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.