The MWE showed below only compiles if the line \usepackage[greek,brazilian]{babel} is removed.





  \psElectricfield[Q={[1 0 0]},linecolor=black] 


Here's an extract of the latex log for the error:

File: main-pics.pdf Graphic file (type pdf)

<use main-pics.pdf, page 1>
Package pdftex.def Info: main-pics.pdf, page1 used on input line 13.
(pdftex.def)             Requested size: 571.13235pt x 572.1361pt.

Overfull \hbox (241.13235pt too wide) in paragraph at lines 13--17


Non-PDF special ignored!
Non-PDF special ignored!
Non-PDF special ignored!<./main-pics.pdf>] (./main.aux))

Here is how much of LuaTeX's memory you used:
 10093 strings out of 494688

Do you know why using Babel causes that error?

  • 2
    Your log-extract shows no error. – Ulrike Fischer Feb 5 '16 at 19:36
  • Well, you're right. Actually, there's no explicit acusation of error anywhere in the log file, but Overleaf prompts the message compile error and gives the option open latex log. Isn't that overfull considered an error? I guess it is the problem, but I can't solve it and don't know why it appears only if the babel package is included. – Leonardo Castro Feb 5 '16 at 21:29
  • 1
    Overfull messages are no errors, but your document needs --shell-escape and so I doubt that you can compile it on overleaf. – Ulrike Fischer Feb 5 '16 at 21:48
  • do you need to use luatex, you could use latex or xetex and pstricks would work natively. – David Carlisle Feb 5 '16 at 22:48
  • @DavidCarlisle In my non-MWE document, I use also some features only allowed with luatex. – Leonardo Castro Feb 6 '16 at 0:17

Browse other questions tagged or ask your own question.