3

The first image is what I have at the moment, the second image is what I would like to get. As you can see, in the second image the formula font size is a little bit bigger than in the first image. I would like to make all the formulas font size a little bit bigger. I tried using, as suggested here, \DeclareMathSizes{14}{15}{7}{7} (note that in beamer I am using 14pt as font size) but it did not produce any effect.

\documentclass[14pt,handout,t]{beamer}
\usepackage{lmodern}
\usepackage[english,italian]{babel}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\geometry{paperwidth=297mm,paperheight=210mm}
\usefonttheme{professionalfonts} 
\renewcommand{\sfdefault}{phv} %change font
\DeclareMathSizes{14}{15}{7}{7}

\begin{document}
\begin{frame}
complesso: $\alpha=\alpha_{r}+i\alpha_{i}$
\end{frame}

\end{document}

enter image description here

enter image description here

3

In your linked question Yiannis writes:

When using the \DeclareMathSizes the first parameter for the text font must be exactly what is used in the class declaration. For example with Beamer rather declare \documentclass[10pt]{beamer}, otherwise the command will appear as it is not working.

That is not a hundred percent correct. You have to use the font size you actually use at the moment. You can output it in the log with

\makeatletter
\show\f@size
\makeatother

and in your MWE this shows

> \f@size=macro:
->14.4.

So the beamer option 14pt uses actually a 14.4pt font size and you have to use

\DeclareMathSizes{14.4}{15}{7}{7}

or

\makeatletter
\DeclareMathSizes{\f@size}{15}{7}{7}
\makeatother

that it works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.