2

I get a problem when creating toc with my style, I want all font size is normalsize, but it doesn't work for the chapter. here my code :

\titleformat{\chapter}[display]{\large\bfseries\fillast }{BAB \thechapter}{0pt}{}
\titlespacing{\chapter}{0pt}{-0.275in}{20pt}
\chapterfont{\normalfont\centering}
\chaptertitlefont{\centering\normalfont}

\renewcommand{\cfttoctitlefont}{\hfill\normalfont\bfseries\MakeUppercase}
\renewcommand{\cftchapfont}{\normalfont}
\renewcommand{\cftchappagefont}{\normalfont}
\renewcommand{\cftaftertoctitle}{\hfill}
\renewcommand{\cftchapleader}{\normalfont\cftdotfill{\cftchapdotsep}}

and the result:

enter image description here

How to set the font size of the chapter to normalsize?

3

It looks like you're using the tocloft package, right? If so, have you tried the instruction

\renewcommand{\cftchapfont}{\normalsize\bfseries}

which should set the font size of chapter-level entries in the TOC

  • yes, I use the tocloft package, yes, I have tried that istruction and give the same result – Verly Sep 22 '11 at 9:20
  • According to your MWE, you've been using the \normalfont instruction inside \cftchapfont -- which affects the font style but not its size -- rather than \normalize. That's why I suggested you try \normalsize. Oh, I've updated the answer to show that you should probably also specify \bfseries as an argument to \cftchapfont. – Mico Sep 22 '11 at 11:08
  • yes, it's running well in miktex. but my problem is in lyx.now, I have solved my problem in lyx : change manually the chapter by right click the capter -> text style -> (setting) -> apply. and without any change my code above in latex preable. Thanks Marco :-) – Verly Sep 22 '11 at 12:10
  • Glad you found a solution! – Mico Sep 22 '11 at 13:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.