2

This is my first question here. I have been reading very useful answers for years. Now, I did not find one that solves my problem.

I am typestting a book with the memoir class, and I am finding the following issue with figures' and tables' captions: When the caption is more than one line long, the caption's text is typeset right-justified, and very often without any hyphenation, which may result in a very wide blank space between the caption's name+number and the real text, plus too much horizontal spacing in the caption's lines. Even when in some cases there is some hyphenation, I also get a wide blank space after name+number.

I tried to set several parameters (\captionstyle, \captionwidth), I have also added discretionary hyphens \-, but the problem, in slightly different ways, seems to persist. Even when the blank after name+number seems wider than the unhyphenated word, and when I put \captionstyle{raggedrigth}, LaTeX insists in putting a wide blank after name+number.

Is this a kown issue ? Should I use the caption package ?

closed as unclear what you're asking by egreg, Zarko, Svend Tveskæg, user13907, Mico Feb 9 '16 at 1:10

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • Memoir incorporates the functionality of the caption package, so you should be able to use Memoir's commands alone. – musarithmia Feb 8 '16 at 18:44
  • @AndrewCashner Not quite true, the caption package can do much more that what the memoir interface offers. – daleif Feb 8 '16 at 19:01
3

The caption styles are describe on section 10.5, page 183 in Memoir manual. It enable powerful formatting of caption appearance.

I use the following (quite nonstandard) caption style:

\captiondelim{\null\newline}
\captionnamefont{\small\sffamily\bfseries}
\captiontitlefont{\small\sffamily\linespread{.84}\selectfont}
\captionstyle[\raggedright]{}
\normalcaptionwidth
\captiontitlefinal{.}
\setlength\belowcaptionskip{.5ex}

For more particular answer you need to provide Minimal Working Example, which will show, what is your problem.

0

PROBLEM SOLVED ... side effect of another (badly executed) hack ... !!!

The problem was very strange. Besides it, I had also noticed that my headlines had become right shifted ... so I began to revise what had I done just before getting into the problem ... weak memory (over sixty) ... but finally I got it: I wanted to change the \abovedisplayskip value for displayed formulas and the like. This you have to do by modifying \normalsize and \small, which I did by using memoir's great \addtodef facility ... so far, so good, great displayed formulas ... but the way I did this introduced four unwanted and non-cancellable spaces in front of the text every time the macros \normalsize and \small were called, and this was the case in every \caption and in the headlines, which are set in \small size ...

I added % at the appropriate places (ends of macros before breaking lines of code) and now everythings works as desired.

Thanks, zarko, for your interest.

Not the answer you're looking for? Browse other questions tagged or ask your own question.