2

I'm trying to prepare a manuscript for PNAS and am running into issues with a table. As in this question/answer, the table is placed after the \end{article}. However, when compiling the document, the table title still isn't shown, nor are \tablenotes. I've narrowed it down to the siunits package, which I used and when removing it (and all uses of \SI) I get the title back. I would prefer to keep using siunits. Is there a way around this or should I start a Word document (ok, empty threat)?

\documentclass{pnastwo}

\usepackage{booktabs}
\usepackage{multirow}
\usepackage{siunitx} % makes the table screwed up...
\usepackage[T1]{fontenc}
\usepackage{amsmath}

\begin{document}

\title{Paper title}

\author{Avi Ginsburg \affil{1}{Somewhere over the rainbow}}

\contributor{Submitted to Proceedings of the National Academy of Sciences
        of the United States of America}

\significancetext{Quite insignificant.}

\maketitle

\begin{article}
    \begin{abstract}
    {
        abstract (adjective) existing in thought or as an idea but not having a physical or concrete existence.
    }
    \end{abstract}

    \dropcap{H}ello world. Small is $\SI{1}{\angstrom}$ or so.

    \begin{acknowledgments}
        We are grateful to egreg for expressing sympathy for those who have to use the PNAS class.
    \end{acknowledgments}

    \end{article}

    \begin{table*}[ht]
        %   \centering
        \caption{Table title - We like to see them}
        \begin{tabular}{c c c }
            \toprule
            &
            \textbf{Something} & \textbf{Else} \\ 
            & & \\ 
            \midrule
            \multirow{6}{*}{\rotatebox[origin=c]{90}{Random}}
            &   accidental\tablenote{this is a table note} &  \\ 
            &   aimless & \\ 
            &   arbitrary & \\ 
            &   incidental & \\ 
            \cmidrule{2-3}
            &   indiscriminate & \\ 
            &   irregular & \\ 
            \midrule
            \multirow{5}{*}{\rotatebox[origin=c]{90}{Example}}
            & case & \\ 
            & illustration&\\ 
            & lesson &\\ 
            \cmidrule{2-3}
            & object & \\ 
            & part & \\ 
            \bottomrule
        \end{tabular}
        \label{tbl}
    \end{table*}

\end{document}

I tried adding this answer to the preamble and changing the class file. This helps somewhat, as the title/caption is shown, however the style is changed and \tablenotes are still not shown below the table.

  • No real solution, but try \captionof{table}{....} (load the caption package!) -- it works with siunitx then too, but I have no clue where the culprit is – user31729 Feb 9 '16 at 11:50
  • 1
    @ChristianHupfer the problem then becomes that the style is wrong as well as the placement of the table. There is definitely something in siunitx that the class doesn't like. The caption package also gives you a warning about incompatible class. – ArTourter Feb 9 '16 at 12:09
  • Using \RequirePackage{siunitx} before the \documentclass{...} works better but then the space between the cells in the table gets squashed – ArTourter Feb 9 '16 at 13:13
  • 1
    The problem here isn't siunitx per se, it's the (standard) array package. The latter is used by siunitx to extend the tabular syntax. As array is part of the base LaTeX distribution, the class here is badly defective. – Joseph Wright Feb 10 '16 at 8:39
  • I'm sorry, but the class is not compatible with array. This means either PNAS or siunitx, not both. – egreg Feb 10 '16 at 15:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.