freshly installed lyx on arch linux, and the 'view buffer' button as well as the shortcut (Ctrl+r) are disabled, I read somewhere that it's necessary to set the default output format at:

'Tools -> Preferences -> File Handling -> File Format'.

However, the only options I have there are DVI, and DVI(LUATEX), and when I choose any of them it fails to compile.

I want to compile a pdf so I mye questions is:

How do I add a default option to compile to a PDF?

A guess of mine (after searching a bit more) is to add a path to the pdflatex compiler, or something like that, under 'Paths', but I don't know what path that would be.

  • 1
    You should not have to set the default output format. The problem is that LyX is not finding the necessary components. Look at the output from LyX's "configure". Start LyX from the command line and then go to Tools > Reconfigure. Look at the terminal output. You will see what LyX is finding and what it is not finding.
    – scottkosty
    Feb 9, 2016 at 22:43
  • @scottkosty erm... I did that... but I don't know what to look for. I don't use latex and I don't know what I need to see in the terminal output.
    – NivPgir
    Feb 10, 2016 at 11:15
  • one thing that should be available is pdflatex. is the directory containing it in your PATH?
    – scottkosty
    Feb 10, 2016 at 15:32

3 Answers 3


I had a similar issue occur, where some configuration error kicked out the converters needed for PDF export (see NivPgir's answer).

In order to restore PDF as output format however, I had to change the setting Tools → Preferences → File Handling → File Formats → Default Output Formats → With TeX fonts back to PDF (pdflatex).

  • This solved it when I had this problem on an Ubuntu install of LyX 2.3.3 Oct 13, 2019 at 2:44

What solved it eventually was adding a 'Lyx -> pdflatex' converter at: Preferences->File Handling->Converters

I used the default configurations, and it magically fixed it


LuaTeX mode has a separate default output format buried here in the global preferences. In my case it was DVI, for some reason.

Just change With non-TeX fonts: to PDF (LuaTeX) (See lowest option in the dialog window below):

enter image description here

n.b. I don't claim that this answers the details of the OP's question well, but it addresses this question's title.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .