0

My whole problem started when I upgraded Adobe Reader to the version DC, it crashed down my LaTeX, I replaced the DC version by the older one.

I remove MiKTeX and TeXnicCenter and installed them again, I kept everything by default, now when I open TeXnicCenter for the first time it asked me about the directory so I put C:\Program Files\MiKTeX 2.9\miktex\bin but it keeps give me the following error message

"The application "Latex" has not been found in the directory of your tex-distribution"

What is the problem?

  • 1
    Without some specific detail such as there erro messages it i impossible to answer this. – Andrew Feb 9 '16 at 19:49
  • Tried other pdf viewers to check if the problem is about texniccenter or miktex? – Enrico Maria De Angelis Feb 9 '16 at 20:51
  • 1
    The error message says exactly the following: The application "Latex" has not been found in the directory of your tex-distribution – Ahed Feb 9 '16 at 20:55
  • If you go to Build->Define Output Profiles.. the path to (La)TeX compiler should specify which version (e.g. pdflatex.exe) to run, depending on which option is selected (e.g. LaTeX=>PDF). Use the (...) button to browse. BTW, my path includes a \x64\ after bin. – John Kormylo Feb 9 '16 at 22:01
  • Ok, I got the directory problem solved... now I got another problem, I compiled a simple latex file it works very well, then another one it gives 3 errors: the first says..fancyhdr.sty not found... – Ahed Feb 10 '16 at 19:56
1

The best practice to install MiKTeX, TeXnicCenter and Adobe or better SumatraPDF do the following:

  1. Download the installer program for MiKTeX (I suggest the complete installation, so use net installer to avoid missing packages like your fancyhdr.sty!)
  2. Install MiKTeX
  3. Download SumatraPDF and install it. SumatraPDF has not to be closed while compiling a new pdf file (Acrobat has to be closed!).
    Alternative: install Acrobat Reader ...
  4. Download the current installer for TeXnicCenter
  5. Install TeXnicCenter. In this order TeXnicCenter is able to find out that MiKTeX is installed and does a lot of configuration things by its own ... That solves for example your problem with the path ... While configuration you are asked to search/add the path for SumatraPDF.

To install new packages to MiKTeX please do only use the MiKTeX package manager for that, this program is desiged to do adding packages for you. You can choose the new needed packages from a list of available packages ...

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.