1

Evening,

I have two references in my bibliography file that display all the authors instead of (Author et al., year)

I have this at the start of my file:

\documentclass[12pt]{article}
\usepackage[round]{natbib}
\begin{document}

\citep{Lloyd2009, Mainprice2014a, Mainprice2014}

\bibliographystyle{agsm}
\bibliography{transfer}

\end{document}

The output is displayed here

(Lloyd et al. 2009; Mainprice et al., 2014a, 2014b)

I do not want to force single authors throughout my document as I also have a lot of two author papers that correctly display as (Author1 and Author2, year).

The Mainprice paper displays all authors and from what I can see is no difference to the Lloyd paper that displays as (Lloyd et al., 2009).

@article{Lloyd2009,
author = {Lloyd, Geoffrey E. and Butler, Robert W.H. and Casey, Martin and Mainprice, David},
journal = {Earth and Planetary Science Letters},
number = {1-2},
pages = {320--328},
title = {{Mica, deformation fabrics and the seismic properties of the continental crust}},
volume = {288},
year = {2009}}

@article{Mainprice2014,
author = {Mainprice, D. and Bachmann, F. and Hielscher, R. and Schaeben, H.},
doi = {10.1144/SP409.8},
journal = {Geological Society, London, Special Publications},
pages = {1--21},
title = {{Descriptive tools for the analysis of texture projects with large datasets using MTEX: strength, symmetry and components}},
volume = {409},
year = {2014}}

@article{Mainprice2014a,
author = {Mainprice, D. and Bachmann, F. and Hielscher, R. and Schaeben, H. and Lloyd, G. E.},
journal = {Geological Society, London, Special Publications},
pages = {1--48},
title = {{Calculating anisotropic piezoelectric properties from texture data using the MTEX open source package}},
volume = {409},
year = {2014}}

My question is similar to this unanswered question, but due to being new to StackExchange, I do not have the sufficient reputation to ask if she found a way to fix it. https://tex.stackexchange.com/q/252130/98008

I also have other references where the first author and year are the same, but they come up as (Author et al., 2016a, 2016b)

Thanks in advance, Amicia

2
  • 1
    Please show us a complete, compilable code (MWE) that we can see your document class and the used options and the way you called your bibliography.
    – Mensch
    Commented Feb 10, 2016 at 19:09
  • Which bibliography style do you use? agsm, by any chance?
    – Mico
    Commented Apr 6, 2016 at 21:07

1 Answer 1

0

I think the reason why all authors are shown for the two “Mainprice” papers is that they do not have the exact same set of authors. So reducing both to “Mainprice et al.” would make the reference ambigious. I checked this by removing “Loyd” from the “Mainprice2014a” paper and then all citations are properly reduced to the “et al” form; complete with 2014a,b for the “Mainprice” cases: (Lloyd et al., 2009; Mainprice et al., 2014a,b). I do not know a good workaround for this. Except for maybe switching to biblatexinstead?

Not the answer you're looking for? Browse other questions tagged .