3

I'm tring to use Biber and Glossaries also with different languages in a document. Actually, everything is working well, but it outputs some errors which are more warnings because the correct PDF is also produced. Nevertheless, the errors are irritating me in my development environment Eclipse with Texlipse Plugin.

Here is my MWE:

\documentclass[12pt]{article}
\usepackage{filecontents}
\begin{filecontents*}{superBib.bib}

@book{bohm_sys,
    title = {System-Entwicklung in der Wirtschaftsinformatik},
    isbn = {978-3-7281-2762-4},
    pagetotal = {702},
    publisher = {vdf Hochschulverlag {AG}},
    author = {Böhm, Rolf},
    date = {2002},
    langid = {german},
    keywords = {Systemdenken}
}

@online{james_scrum_2012,
    title = {Scrum Reference Card},
    url = {http://scrumreferencecard.com/ScrumReferenceCard.pdf},
    titleaddon = {Scrum Reference Card},
    type = {Knowledge},
    author = {James, Michael},
    date = {2012},
    keywords = {{SCRUM}}
}

\end{filecontents*}

%% BIBER BibLatex  
 \usepackage[backend=biber,style=numeric,sorting=ynt,  natbib=true]{biblatex}%
\addbibresource{superBib.bib}

\usepackage[ngerman,polish,english]{babel}
\usepackage[utf8]{inputenc}
\usepackage[babel,german=quotes]{csquotes}

\usepackage[T1]{fontenc} % 
\usepackage[colorlinks]{hyperref}

\usepackage[acronym,toc,nonumberlist,section]{glossaries}
\makeglossaries

\begin{document}
    \selectlanguage{english}
    %% Set some Acronyms and Glossary Entries
    \newacronym{acr:ram}{RAM}{Random-access memory}
    \newacronym{acr:csv}{CSV}{Comma-separated values}
    \newglossaryentry{glo:btrat}{name={bitrate},description={It effects the file-size and quality of a video}}
    \newglossaryentry{glo:dynamicweb}{name={dynamic website},description={server generated code}}
    \newglossaryentry{glo:staticweb}{name={static website},description={hard coded content, server just delivers the document}}

    %% Print Acronym and Glossary
    \printglossary[type=\acronymtype,style=list, title=List of Abbreviations, toctitle=List of Abbreviations]
    \glsaddall[types=main]      %added all defined Glossentries 
    \printglossary[type=main,style=altlist, title=Glossary, toctitle=Glossary]

    \printbibliography[heading=bibintoc,title={Bibliography}]

    \section{Cites}
        Hello \citet{james_scrum_2012} and another \parencite{bohm_sys}    

    \section{Acr and Glo}

%    Here we use \gls{acr:ram} and followed by a GlossaryEntry: \gls{glo:btrat}

    \selectlanguage{ngerman}
    Hallo Welt

\end{document}

Some Error Message:

! Missing \endcsname inserted.
<to be read again>
                 \bbl@loaded
l.47 \begin{document}


! Extra \endcsname.
\cslet ...>\expandafter \let \csname #1\endcsname
                                                  #2
l.47 \begin{document}

! Extra \endcsname.
\blx@maplang ...d \csname abx@extras@#2\endcsname
                                                  \expandafter \noexpand \cs...
l.47 \begin{document}


! Extra \endcsname.
\blx@maplang ... \csname abx@strings@#2\endcsname
                                              }\csxappto {noextras#1}{\n...
l.47 \begin{document}


("C:\Program Files\MiKTeX 2.9\tex\latex\tools\.tex" File ignored)
! Missing \endcsname inserted.
<to be read again>
                   \bbl@loaded
l.47 \begin{document}

If you uncomment everything that belongs to glossaries one warning remain

! Undefined control sequence.
<argument> ...docsvlist \expandafter {\bbl@loaded
                                    }\ifboolexpr { not test {\...
l.47 \begin{document}

Is it possible that the Babel package is the culprit?

I'm using a small batch file to produce the output - the general steps are:

pdflatex

makeindex -q -s *.ist -t *.alg -o *.acr *.acn

makeindex -q -s *.ist -t *.glg -o *.gls *.glo

biber

pdflatex

pdflatex

Edit: Solution is to update

The babel version was to old - after using the MikTeX Update Manager and not the Package Manager everything is fine now!

closed as off-topic by moewe, Przemysław Scherwentke, user13907, Andrew, Maarten Dhondt Feb 11 '16 at 11:28

  • This question does not fall within the scope of TeX, LaTeX or related typesetting systems as defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    I have no problem with this file / command sequence. Are you sure your biblatex and biber versions match? See Table 1 in the Biber manual for the compatibility matrix if you are unsure. – jon Feb 11 '16 at 2:30
  • 4
    Your babel version is too old for your modern version of biblatex and Biber. The command \bbl@loaded is quite recent and tells biblatex which languages were used. Update MikTeX in both User and Admin mode, see How should one maintain and update a MiKTeX installation?. – moewe Feb 11 '16 at 8:44
  • 1
    @Eric: In a modern system with biblatex there is really no need to use \"u. – Ulrike Fischer Feb 11 '16 at 9:38
  • 1
    Precisely, the Update manager is for updates, the Package Manager doesn't normally do updates for you. Can we close this question as "solved by an update"? – moewe Feb 11 '16 at 9:53
  • 4
    I'm voting to close this question as off-topic because it was solved by an update (see comment above). – moewe Feb 11 '16 at 11:02