1

I'm using the ltablex package because I have some large tables which have to splitted on multiple pages. But I have much more small tables (with tabularx), which don't need to be splitted. But they where splitted :/

How can I avoid that for explicit tables?

I inserted these tables with:

\begin{tabularx}{\textwidth}{lcX}

So I added no floating position tag, like !h or t or something else. I tried it with these, but no change. Only with the float-package and the option H they where not splitted, but then they are on the explicit position in text, what I don't want.

2

The fact that ltablex affects all tabularx is not the best feature of the package, you could instead use ltxtable package but anyway with ltablex as with normal tabularx if you want the tabke to float it must be inside a table environment, and once inside such an environment it will not split as table makes a box. You can not add float options such as [h] to tabular or tabularx.

  • thanks for the hint. Inside the tableenvironment it works now :) – Opa114 Feb 11 '16 at 23:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.