I have my bibtex document with bibliography included. When I insert in the document the first two references, everything goes perfect. But when I add the third reference I got a wron numeration: the second reference appears as "3" and the third as "2". Another important fact is that I am writing my thesis in different chapters, so references are not in an unique .tex file, so I am not sure which MWE to send. I really appreciate your help. Thanks.



\usepackage[spanish, es-tabla]{babel}


In one of the chapters I have:

  (efecto magnetoeléctrico) \cite{manfred_fiebig_revival_2005}.

That is the first reference In other chapter

  tetragonal \cite{mishra_effect_2008}. raras \cite{zhang_effect_2010}. 

Biblio file (just the references showed here, but document contains much more...):

title = {Effects of precursor chemistry and thermal treatment conditions on obtaining phase pure bismuth ferrite from aqueous gel precursors},
volume = {29},
issn = {0955-2219},
url = {http://www.sciencedirect.com/science/article/pii/S0955221909002416},
doi = {http://dx.doi.org/10.1016/j.jeurceramsoc.2009.05.018},
pages = {3007 -- 3013},
number = {14},
journaltitle = {Journal of the European Ceramic Society},
author = {Hardy, A. and Gielis, S. and Rul, H. Van den and D’Haen, J. and Bael, M. K. Van and Mullens, J.},
date = {2009},
keywords = {Multiferroic properties}
title = {Revival of the magnetoelectric effect},
volume = {38},
doi = {10.1088/0022-3727/38/8/R01},
pages = {R123--R152},
journaltitle = {{JOURNAL} {OF} {PHYSICS} D: {APPLIED} {PHYSICS}},
shortjournal = {J. Phys. D: Appl. Phys.},
author = {{Manfred Fiebig}},
date = {2005}
title = {Effect of yttrium on improvement of dielectric properties and magnetic switching behavior in {BiFeO}3},
volume = {20},
pages = {045218},
number = {4},
journaltitle = {Journal of Physics: Condensed Matter},
author = {Mishra, {RK} and Pradhan, Dillip K and Choudhary, {RNP} and Banerjee, A},
date = {2008}
title = {Structural, dielectric and magnetic properties of Bi1-{xYxFeO}3 (0 {\textless}x {\textless} 0.2) obtained by acid–base co-precipitation},
volume = {592},
doi = {10.1016/j.jallcom.2013.12.243},
pages = {306--312},
journaltitle = {Journal of Alloys and Compounds},
shortjournal = {J. Alloys. Comp.},
author = {{Saleh Medina, Leila M.} and {Jorge, Guillermo} and {Negri, R. Martín}},
date = {2014}
title = {Effect of Eu substitution on the crystal structure and multiferroic properties of {BiFeO} 3},
volume = {507},
url = {http://www.sciencedirect.com/science/article/pii/S0925838810018621},
pages = {157--161},
number = {1},
journaltitle = {Journal of Alloys and Compounds},
author = {Zhang, Xingquan and Sui, Yu and Wang, Xianjie and Wang, Yang and Wang, Zhu},
urldate = {2016-02-14},
date = {2010},
file = {Snapshot:C\:\\Users\\L-COM\\AppData\\Roaming\\Zotero\\Zotero\\Profiles\\wvijlgbz.default\\zotero\\storage\\NHSBGTQS\\S0925838810018621.html:text/html}
  • 1
    This is probably due to the style of the bibliography you have chosen. Some of them will enumerate in the order that citations appear, whilst some other will order based on the alphabetical order of the authors. Without a MWE though, it'll be hard to tell. – JP-Ellis Feb 14 '16 at 2:13
  • You make the MWE to be just enough code to reproduce the problem. So yours sill include 3 references. You can either supply a .bib file with 3 entries along with the .tex file or use biblatex-examples.bib which everyone has by default. – cfr Feb 14 '16 at 2:23
  • @JP-Ellis I have just edited the question with a MWE. Thanks! – Leila Feb 14 '16 at 3:18
  • Thanks for updating this; however, it still isn't quite a minimal example. It should start with \documentclass and end with \end{document}. You should also include the bibliography file. I'll still have a go at trying to figure out what's going on. – JP-Ellis Feb 14 '16 at 3:20

The reason the numbers appear out of order in your document is that the bibliography style you are using, chem-angew, sorts the bibliography by author. Typically, I would leave this as it is because that is part of the bibliography style; however, you can always override this as explained in the biblatex manual. In particular, if you just add sorting=none to the biblatex options, then it will sort the entries in the order that they are cited:

TeX File:


\usepackage[spanish, es-tabla]{babel}
  sorting=none,  % <-- Sort in the order they appear





Bib File:

  name={Article 1},
  author={John A},
  journal={Journal A},
  name={Article 2},
  author={John B},
  journal={Journal B},
  name={Article 3},
  author={John C},
  journal={Journal C},



Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.