1

It has been two years since I have started using Latex (on a Mac), and up to now I have written my text without worrying about the possible output (as if it was a WYSIWYG), and at the moment of compiling, I searched all the accented characters and replaced them. It is boring and decided to reattack the problem.

So here is my input (the encoding is in UTF-8):

\documentclass[a4paper,11pt]{book}

\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc} 

\begin{document}
Cet été, dans une forêt française, j’ai ouï un très grand cri.
\end{document}

And the output is:

Undefined control sequence ...

(followed by the text where the accented (+cedille) characters are replaced by their unicode name). I have updated TexShop, tried all the possible compatible pairings of encoding and option of inputenc (isolatin, applemac) without success, and I don't understand where the problem could came from.

Does someone have any idea? Thank you very much in advance.

  • 3
    Welcome to TeX.SX! Your example runs for me. Are you sure your editor is using utf8 actually? – user31729 Feb 14 '16 at 16:26
  • 4
    Please when showing error messages always show the exact multi-line message from ! to ? hard to debug when only show a fragment of the message. I would guess that your file is not saved in UTF-8 format. – David Carlisle Feb 14 '16 at 16:33
  • 2
    The short MWE in your question works absolutely fine for me. Make sure your document is really encoded in UTF-8. Maybe an update of your TeX distribution might help. – moewe Feb 14 '16 at 16:35
  • 4
    In a terminal you can do file filename.tex and the output tells you what encoding your file was saved with. – Johannes_B Feb 14 '16 at 16:47
  • 2
    The default file saving format for TeXShop is (unfortunately) MacRoman. So you need to change your TeXShop preferences to save files as UTF-8. For existing files you can open them and the use Save As (which for recent OS versions is option-Save) and then choose UTF-8 as the encoding for the resaved file. – Alan Munn Feb 14 '16 at 17:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.